httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <ma...@worldgate.com>
Subject Re: Build of apache_19971016130014
Date Tue, 21 Oct 1997 05:58:32 GMT
On Mon, 20 Oct 1997, Dean Gaudet wrote:

> 
> > ----------------------------------- logs/hp9000s700.log -------------------------------
> > LOG Build: apachen hp9000s700 rwanda unix active 1200 Thu Oct 16 11:07:06 EDT 1997
> > LOG: uname -a:HP-UX rwanda B.10.01 A 9000/710 2011145811 two-user license
> >  + configured for HP-UX 10 platform
> > gcc -c  -I../os/unix -I../main    -DHPUX10 -DSTATUS   http_main.c
> > http_main.c: In function `lingering_close':
> > http_main.c:1038: warning: passing arg 2 of `select' from incompatible pointer type
> > http_main.c:1038: warning: passing arg 4 of `select' from incompatible pointer type
> 
> Well, for some reason we're explicitly not defining SELECT_NEEDS_CAST for
> HPUX 10, and only HPUX 10.

Recent versions of HPUX 10.x don't want SELECT_NEEDS_CAST unless you have
some dawg-awful compat. define set.  Early HPUX 10.x things do.  I 
don't know exactly where and I am lazy, so I decreed that HPUX 10.x
doesn't need cast and before does.  If I can find out where the cutoff
is, something can be done...

Anyone have 10.10?  10.01 needs, 10.20 doesn't.



Mime
View raw message