httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From (Rodent of Unusual Size)
Subject Re: [PATCH] Suggestion for HTTP_PROTO(maj,min) macro
Date Thu, 16 Oct 1997 22:56:16 GMT
>From the fingers of Martin Kraemer flowed the following:
>I sometimes wondered if there was a better (or more intuitive) way to say...
>    if (r->proto_num >= 1001) ...
>I would prefer, like,
>    if (r->proto_num >= HTTP_PROTO(1,1)) ...

    I like the concept, but I'd really like a better name for the macro
    - "PROTO" to me means "prototype" more frequently than it does
    "protocol".  I know the field is named "proto_num", but I'm not wild
    about that, either.

    #ken    P-)}

View raw message