httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David D'Antonio" <...@individual.com>
Subject RE: mod_proxy/1163: Proxy Server does not forward http://user:passwd@site correctly (fwd)
Date Thu, 25 Sep 1997 16:58:35 GMT
I've new to this list so I didn't want to post out of turn, but I believe that the syntax below
is for
password-protected web pages. You are correct, of course, that FTP URLs start with ftp://

DDA

-----Original Message-----
From:	Ben Laurie [SMTP:ben@algroup.co.uk]
Sent:	Thursday, September 25, 1997 6:03 AM
To:	new-httpd@apache.org
Subject:	Re: mod_proxy/1163: Proxy Server does not forward http://user:passwd@site correctly
(fwd)

Marc Slemko wrote:
> 
> Erm... that is never supposed to be port of a URL passed to a HTTP server
> is it?

It is also my understanding that FTP URLs start "ftp:"...

Cheers,

Ben.

> 
> ---------- Forwarded message ----------
> Date: Wed, 24 Sep 1997 13:50:02 -0700 (PDT)
> From: Fredy Paquet <fp@opag.ch>
> To: apache-bugdb@apache.org
> Cc: apache-bugdb@apache.org
> Subject: mod_proxy/1163: Proxy Server does not forward http://user:passwd@site correctly
> 
> >Number:         1163
> >Category:       mod_proxy
> >Synopsis:       Proxy Server does not forward http://user:passwd@site correctly
> >Confidential:   no
> >Severity:       non-critical
> >Priority:       medium
> >Responsible:    apache (Apache HTTP Project)
> >State:          open
> >Class:          sw-bug
> >Submitter-Id:   apache
> >Arrival-Date:   Wed Sep 24 13:50:02 1997
> >Originator:     fp@opag.ch
> >Organization:
> apache
> >Release:        1.2.4
> >Environment:
> Sun Solaris 2.4 / gcc 2.7.1
> Netscape 3.0.1
> >Description:
> Trying to access a password protected ftp site via proxy will always
> result in the same error message:
> 
> Bad Request
> Your browser sent a request that this server could not understand.
> 
> ---
> Additional info:
> - Connecting directly w/o proxy is working
> - Connecting via Cern Proxy server is working
> - Connecting via Apache 1.2.1 or 1.2.4 is NOT WORKING
> >How-To-Repeat:
> 
> >Fix:
> 
> >Audit-Trail:
> >Unformatted:

-- 
Ben Laurie            |Phone: +44 (181) 994 6435|Apache Group member
Freelance Consultant  |Fax:   +44 (181) 994 6472|http://www.apache.org
and Technical Director|Email: ben@algroup.co.uk |Apache-SSL author
A.L. Digital Ltd,     |http://www.algroup.co.uk/Apache-SSL
London, England.      |"Apache: TDG" http://www.ora.com/catalog/apache

Mime
View raw message