httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <r...@imdb.com>
Subject make failure; no binary (fwd)
Date Tue, 26 Aug 1997 19:38:06 GMT

Presumably the binaries are there but named something other than httpd ?

Shouldn't this compile out of the box though ?

---------- Forwarded message ----------
Date: Tue, 26 Aug 1997 10:30:05 -0500
From: Darrell Kachilla <drk@mutt.mdacc.tmc.edu>
To: apache-bugs@apache.org
Subject: make failure; no binary

 Subject: make failure
X-Sun-Charset: US-ASCII
content-length: 1818

recon{drk}352% uname -a
SunOS recon 4.1.3_U1 6 sun4m


/PHYS/Apache_1.2.3-nonbinaries/src
recon% ./Configure
./Configure: Command not found.
recon% cd src
recon% ./Configure
Using config file: Configuration
Using Makefile template file: Makefile.tmpl
 + configured for SunOS 4 platform
 + setting C compiler optimization-level to -O2
recon% make
(cd regex; make lib CC=gcc AUX_CFLAGS='-O2 -DSUNOS4 -DUSEBCOPY ' RANLIB='ranlib')
rm -f *.o
sh ./mkh  -i _REGEX_H_ regex2.h regcomp.c regerror.c regexec.c regfree.c >regex.tmp
cmp -s regex.tmp regex.h 2>/dev/null || cp regex.tmp regex.h
rm -f regex.tmp
sh ./mkh  -p regcomp.c >regcomp.ih
gcc -I. -DPOSIX_MISTAKE -O2 -DSUNOS4 -DUSEBCOPY    -c regcomp.c -o regcomp.o
sh ./mkh  -p engine.c >engine.ih
gcc -I. -DPOSIX_MISTAKE -O2 -DSUNOS4 -DUSEBCOPY    -c regexec.c -o regexec.o
sh ./mkh  -p regerror.c >regerror.ih
gcc -I. -DPOSIX_MISTAKE -O2 -DSUNOS4 -DUSEBCOPY    -c regerror.c -o regerror.o
gcc -I. -DPOSIX_MISTAKE -O2 -DSUNOS4 -DUSEBCOPY    -c regfree.c -o regfree.o
rm -f libregex.a
ar crv libregex.a regcomp.o regexec.o regerror.o regfree.o
a - regcomp.o
a - regexec.o
a - regerror.o
a - regfree.o
ranlib libregex.a
gcc -c -Iregex  -O2 -DSUNOS4 -DUSEBCOPY   alloc.c
alloc.c: In function `pstrcat':
alloc.c:407: too many arguments to function `__builtin_next_arg'
alloc.c:421: too many arguments to function `__builtin_next_arg'
alloc.c: In function `table_do':
alloc.c:684: too many arguments to function `__builtin_next_arg'
make: *** [alloc.o] Error 1
------------------------------------------------------------------------
so...
tried retrieving 1.2.3 binaries  from 
http://www.ameth.org/apache/dist/binaries/sunos_4.1.x/

...tried both tar files
...neither has the httpd  in src
	or any other directory for that matter.  :-(


tried again with copy in www.apache.org/dist/binaries/sunos_4.1.x/
...nope

 
have earlier version working ok on solaris 2.5.1 though.  :-)

what am i doing wrong?
or let me know when binaries available.


thanx



------------------------------------------------------------------------
Darrell Kachilla  - working but not speaking for...
   M.D. Anderson Cancer Center, Diagnostic Imaging -57
   1515 Holcombe Blvd.,   Houston, Tx 77030
drk@rpisun1.mdacc.tmc.edu     W: 713-745-2361	FAX: 713-745-0581
http://recon.mdacc.tmc.edu
 


Mime
View raw message