httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Kraemer <>
Subject ap_ prefix to funcs (was: Re: patches from "Paul B. Henson")
Date Wed, 27 Aug 1997 13:47:41 GMT
Doug MacEachern wrote,...
> ... I suppose
> we should prefix them with ap_ instead of apache_ to be consistent.
> The patches look fine to me, +1.  If the other changes look okay to
> the os gurus, I'll take care of s/apache_/ap_/g and the commit.

On a related topic: should the replacement routines which are included
via NEED_<func> defines (main/util.c) be prefixed as well? I think of
something like

    extern int ap_strcasecmp(...);
    #define  strcasecmp(str1,str2)  ap_strcasecmp(str1,str2)

in util.c:

This would reduce the risk of a clash with other "replacement" functions
of the same name (like, e.g., in libphp.a).

| S I E M E N S |  <>  |      Siemens Nixdorf
| ------------- |   Voice: +49-89-636-46021     |  Informationssysteme AG
| N I X D O R F |   FAX:   +49-89-636-44994     |   81730 Munich, Germany
~~~~~~~~~~~~~~~~My opinions only, of course; pgp key available on request

View raw message