httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Sutton <>
Subject Re: [PATCH] PR#344: 64-bit cleanup
Date Sun, 13 Jul 1997 16:17:56 GMT
On Sat, 12 Jul 1997, Dean Gaudet wrote:
> Or is everyone agreeing to my statement that we could have both
> cmd_info_ptr and cmd_info_int ?  What are you agreeing with?

I _think_ the issue is whether we really want to have a single field
holding both int and pointer values in the directive definition in the
API. While it has be traditional in some parts of Apache to use (void*) 
and int interchangeable, it is inappropriate with newer system and isn't
generally a good idea. Your patch fixes this (I guess - I don't have any
64 bits systems to test it on, but the code look fine). I just object to
turning cmd_info into a generic data item. It is open to confusion. 

If we really cannot store the XtOffsetOf value into this as a pointer (and
I quite agree why in theory that is bad, but in practise I think we can
successfully cast XtOffset appropriatley, via a (long) if necessary), then
I definitely support your idea of adding a new integer item.

> On Wed, 9 Jul 1997, Jim Jagielski wrote:
> > +1 ditto
> > sameer wrote:
> > > +1 here too
> > > > At 11:20 AM 7/9/97 +0100, you wrote:
> > > > >I think that having a
> > > > >single value to hold both int and pointer values is generally an evilness,
> > > > >so I would prefer to _define_ the cmd_info field of the directive
> > > > >definitions as a pointer in the API, and not define it as a generic
> > > > >type. Is there any module which is actually using it to store int
> > > > 
> > > > I strongly agree with this.


View raw message