httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <ma...@worldgate.com>
Subject Re: Netscape Bug
Date Tue, 03 Jun 1997 23:55:01 GMT
On Tue, 3 Jun 1997, Aram Mirzadeh wrote:

> Marc Slemko said:
> > 
> > On Tue, 3 Jun 1997, Aram Mirzadeh wrote:
> > 
> > > 
> > > 
> > > Anyone remember what the PR# of the netscape image problem was?  I'm running
> > > 1.2b11 and it seems to be showing up again. 
> > 
> > If the headers are a certain length (~256 bytes?), Netscape doesn't read
> > the file properly.  Try adding a bflush after the headers are sent and see
> > if that fixes it...  
> 
> That does fix it, but then everything is alot slower it seems.

It does!?!  Are you _sure_?  You added a flush, cleared both memory and
disk cache, and went to the page?

> 
> > It is entirely possible that there are other lengths that cause the same
> > thing...
> 
> I'll check into it to see if I can pick it out of the air. 

It looks to me like Communicator isn't properly handling the BASE tag.
You have a:

	<BASE HREF="http://forcep.qosina.com/">

But Communicator is sending a request for:

	GET /cgi-bin/images/clickreq.gif HTTP/1.0
	Referer: http://forcep.qosina.com/cgi-bin/genpart.cgi?z=0&p=11020/GR
	Connection: Keep-Alive
	User-Agent: Mozilla/4.0b5 [en] (WinNT; I)
	Host: forcep.qosina.com
	Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg
	Accept-Language: en
	Accept-Charset: iso-8859-1,*,utf-8

So it gets a:

	HTTP/1.1 404 File Not Found
	Date: Tue, 03 Jun 1997 23:47:27 GMT
	Server: Apache/1.2b11
	Connection: close
	Content-Type: text/html

[...]

Your access logs should show a lot of requests for /cgi-bin/images/foo
instead of /images/foo...


Mime
View raw message