httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <r...@imdb.com>
Subject Symbolic link oddity in Apache (fwd)
Date Thu, 17 Apr 1997 00:01:33 GMT

not acked


---------- Forwarded message ----------
Date: Thu, 17 Apr 1997 00:36:14 +0100 (BST)
From: WWW server manager <webadm@info.cam.ac.uk>
To: apache-bugs@apache.org
Subject: Symbolic link oddity in Apache

I've mentioned this before (in relation to V1.1.1 last August), but in spite
of it appearing to be a (fairly significant) bug, it's still there in 1.2b8
(just tripped over it again...) and no-one leaped in to say it was a feature 
rather than a bug when I mentioned it before...

The problem is that for the server to follow a symbolic link, it appears
to be necessary for the directory which is the target of the link to have the 
FollowSymLinks option enabled, even though the documentation says:

"[Options] FollowSymLinks 
   The server will follow symbolic links in this directory." 

which seems entirely unambiguous, but does not seem to correspond to reality.
It could be argued that it says nothing about whether the option must
also be set for the target of the link, I suppose, but requiring it to be
set for the target directory would be distinctly unhelpful (as well as 
counterintuitive), especially if the target directory needed all options
definitively turned off because it would be updated by untrusted people.

                                John Line


-- 
University of Cambridge WWW manager account (usually John Line)
Send general WWW-related enquiries to webmaster@ucs.cam.ac.uk



Mime
View raw message