httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject PR#502: timeout problems
Date Wed, 30 Apr 1997 23:41:08 GMT
Looks like something wrong in Roy's latest round of timeout changes.  If I
get a chance I'll go through them line by line looking for irix specific
problems.  Ugh. 

Mark, another snapshot after you tweaked your config would be great. 
Thanks. 

Dean

---------- Forwarded message ----------
Date: Wed, 30 Apr 1997 01:31:52 -0500 (CDT)
From: "Mark A. Bentley" <bentlema@cs.umn.edu>
To: Dean Gaudet <dgaudet@arctic.org>
Cc: new-httpd@apache.org
Subject: Re: Keep-Alive


I've upgraded to 1.2b10, and have bee nwatching the server for awhile.
It looks like some keep-alive request die exactly as they should on the
configured timeout, but others continue to hang around for times well
greater than the KeepAliveTimeout, and the server Timeout.  Just as an
example, my server shows an uptime of 8 hours, and there are a couple
keep-alives with the "SS" field of >24000 seconds.

This could be an IRIX 5.3 problem, but it seems odd that this  problem
didn't show itself until 1.2b9 and 10, right about the same time the new
signal handling code was written for  "graceful restart." 

       --Mark.

--
Mark A Bentley			Email:	bentlema@cs.umn.edu
Systems Staff, CSci Dept
University of Minnesota 	URL:	http://www.cs.umn.edu/~bentlema/



---------- Forwarded message ----------
Date: Wed, 30 Apr 1997 07:19:20 -0700 (PDT)
From: "Mark A. Bentley" <bentlema@cs.umn.edu>
To: Dean Gaudet <dgaudet@arctic.org>
Cc: new-httpd@apache.org
Subject: Re: Keep-Alive Debugged



After fiddling with my server configuration, I think I've found an answer
to the "lingering Keep-Alive" problem.  I had configured Keep-Alives
outside of all Virtual Hosts, assuming that these directives would apply
to all Virtual Hosts.  As a test, I turned off Keep-Alives in the
so-called "global" section, and placed those three directives in one
specific Virtual Host.  After watching the server for about a half hour
it seems to behaving normally.

I'm not sure if this is a bug or not, but thought I'd let you know...

Thanks,

   Mark.


--
Mark A Bentley			Email:	bentlema@cs.umn.edu
Systems Staff, CSci Dept
University of Minnesota 	URL:	http://www.cs.umn.edu/~bentlema/





---------- Forwarded message ----------
Date: Wed, 30 Apr 1997 09:51:19 -0700 (PDT)
From: "Mark A. Bentley" <bentlema@cs.umn.edu>
To: Dean Gaudet <dgaudet@arctic.org>
Cc: new-httpd@apache.org
Subject: Re: Keep-Alive Debugged


Damn, you can scratch that last theory.  It's now a couple hours later,
and there are about 40 Keep-Alives hanging around.  A graceful-restart
clears them out nicely, though they seem to come back slowly and in
ever-increasing numbers.

I do have an IRIX 6.2 box I could test on, but I don't have any way to
simulate the server load we get on our CS server.

--
Mark A Bentley			Email:	bentlema@cs.umn.edu
Systems Staff, CSci Dept
University of Minnesota 	URL:	http://www.cs.umn.edu/~bentlema/



Mime
View raw message