httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <>
Subject Re: graceful restarts, take 5
Date Tue, 22 Apr 1997 20:09:36 GMT
On Tue, 22 Apr 1997, Roy T. Fielding wrote:
> >For take 6 I am going to include Roy's second suggested change to
> >new_block().  But I'm going to skip the ap_foo() cleanups suggested by Jim
> >and submit them post 1.2. 
> You mean moving them to conf.h, right?

Yep they'll just stay in http_main.c and I won't make ap_select().

> One thing I'd like to establish is a policy of not changing the API
> magic number on 1.2.x releases; if it requires 3rd-party module writers
> to recompile and redistribute their code, then it is more than a minor
> revision.

It would be nice if we just had a major/minor API scheme numbering.  Changes
like ap_foo() are backwards compatible.

Something I haven't considered:  I killpg SIGUSR1 the process group... how
CGIs react to that is questionable.  I'll see today I suppose, the servers
I've been testing on up until now do not have any CGIs.


View raw message