httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject Re: Apache 1.2b7 / linux 2.0.29 (fwd)
Date Mon, 17 Mar 1997 07:55:22 GMT
A whole bunch of these so-called "linux problems" are because the people
run multiple servers with the same ScoreBoardFile.  At least that's what
I've been discovering.  It would be nice to have some way to detect when
two servers are trying to share the same file. 

I've been running my linux box with -DHAVE_SHMGET for weeks now without a
problem. 

Dean

---------- Forwarded message ----------
Date: Sun, 16 Mar 1997 22:36:34 -0800 (PST)
From: Josh Beck <jbeck@connectnet.com>
To: "Scott J. Ellentuch" <tuc@tucslap.stormking.com>
Cc: linux-kernel@vger.rutgers.edu
Subject: Re: Apache 1.2b7 / linux 2.0.29

This problem is still occuring. It has only occured on two machines
ever, that I personally know of, and I can only observe it on the current
machine. The only thing that differentiates BOTH machines from all others
is the heavy use of DBM... and this problem seems to be there regardless
of kernel/apache version, but only occurs when a third copy of apache is
running. I think, although I can't be positive, that there is a trend in
that the server which dies off is the one with the largest amount of DB
access... perhaps a lib problem? or a kernel problem? Sorry to mail the
list if this isn't a kernel issue.

Even 2.0.29/ISS patch 4 suffers from this, haven't tried 2.1.x yet,
though.

Josh Beck                                           jbeck@connectnet.com
------------------------------------------------------------------------
CONNECTNet INS, Inc.        Phone: (619)638-2020      Fax: (619)450-3216
6370 Lusk Blvd., Suite F-208                         San Diego, CA 92121
------------------------------------------------------------------------

On Sun, 16 Mar 1997, Scott J. Ellentuch wrote:

> In Josh Beck' own words (And I ">_") :
> > 
> > Does anyone have any idea when using this combination (or actually all
> > apache / linux combinations I've tried), when you try to run a third
> > virtual server (ie, three total, seperate copies of apache running on
> > different interfaces w/ diff. config files, etc), the first will start to
> > get lots of errors and then just hang, running but not answering queries?
> > 
> > Any help would be appreciated... it's a ppro with very standard hardware,
> > 3c509... I haven't observed this before, and have had more servers running
> > on linux. Could it have to do with the use of DB files for password auth?
> > That's the only special circumstance here, and that it is a PPro,
> > otherwise everything I can think of I know works. Any hints would be
> > appreciated.
> > 
> 	What ever happened with this?  I run an older Apache on 2.0.22 with
> no worries (PP200)
> 
> 			Tuc/TTSG
> 
> -- 
> Scott J. Ellentuch, The Telecom Security Group/TTSG, Newburgh, NY
> Visit our Web Site at http://www.ttsg.com/
> 
> "Over the UUCP link, out the ethernet, through the media converter, down
> the fiber, off a router, down the 56K, past my ISP...nothing but Net" -
> with poetic license from Dave Owen of IBM
> 



Mime
View raw message