httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject Re: [BUG]: "gethostbyname gets broken for some versions of FreeBSD" on FreeBSD (fwd)
Date Thu, 06 Mar 1997 08:06:23 GMT
I know it sounds obvious, but can you ping or telnet to the ServerName
while logged into the webserver? 

I've included a patch against 1.2b7 which uses herror() to display more
info about why it failed in any of the cases where the server does
namelookups and exits on failure... it might help. 

Dean

On Tue, 4 Mar 1997, Rob Hartill wrote:

> 
> not acked.
> 
> ---------- Forwarded message ----------
> Date: Mon Mar  3 21:05:58 1997
> From: john@starfire.mn.org
> To: apache-bugs%apache.org@organic.com
> Subject: [BUG]: "gethostbyname gets broken for some versions of FreeBSD" on FreeBSD
> 
> Submitter: john@starfire.mn.org
> Operating system: FreeBSD, version: 2.1.6/7
> Version of Apache Used: 1.2b7
> Extra Modules used: 
> URL exhibiting problem: 
> 
> Symptoms:
> --
> Using either your "out-of-the-box" distribution, or after having
> been patched through the FreeBSD-current ports support, the
> gethostbyname at line 1453 of http_main.c returns a NULL, even
> though the s->server_hostname appears correct, causing the program
> to report "httpd: cannot determine the IP address of
> the specified ServerName (workbench1.skypoint.net)" even though
> that name is perfectly resolvable.  Look, I
> know this sounds bizarre, and I wouldn't know how to cause it
> if I wanted to, but I'm just reporting what I'm seeing!
> 1.1.1 does not have this problem.  I'm just trying
> --
> 
> Backtrace:
> --
> 
> --
> 
> 
> 

Mime
View raw message