httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy T. Fielding" <field...@kiwi.ICS.UCI.EDU>
Subject Re: Apache_1,2b7 Compilation Error (fwd)
Date Mon, 31 Mar 1997 23:48:41 GMT
>Have just tried to compile Apache_1.2.b7 on my Sparc and have come up 
>with the following error.  Is this a bug or am I doing something 
>wrong ?  I have listed the system details below and the compilation 
>error given.
>
>TIA
>Gordon
>
>System Details:
>SPARCStation 1+
>SunOs 4.1.3
>gcc v2.6.0
>
>Error:
>
>In file included from http_main.c:79:
>httpd.h.677: conflicting types for 'strerror'
>/usr/GNU/lib/gcc-lib/sparch-sun/sunos4.1.3/2.6.0/include/string.h:31: 
>previous declaration of 'sterror'
>*** Error code 1
>make: Fatal error: Command failed for target 'http_main.o'

I have 1.2b7 working fine on SunOs 4.1.2.  The only difference is that
you are using an old version of gcc.  You should be using 2.7.2 (or later)
which has been available for more than a year now.

.....Roy

Mime
View raw message