httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Howard Fear <...@pooh.pageplus.com>
Subject Re: [BUG]: "SSI stopped working in 1.2b7" on Solaris 2.x (fwd)
Date Sat, 08 Mar 1997 16:15:34 GMT

>> Submitter: roy@atlantic.net
>> Operating system: Solaris 2.x, version: 2.5
>> Version of Apache Used: 1.2b7
>> Extra Modules used: php, fastcgi, msql
>> URL exhibiting problem: 
>> 
>> Symptoms:
>> --
>> When I run b7 instead of b6, the SSI commands we use, in combination
>> with XBitHack full  stop working. The raw SSI commands are left in the
>> delivered document. Killing httpd and running 1.2b6 instead immediatly
>> brings the SSI back into operation.

I've tried a variety of configuration options and I can't reproduce
this on my lowly Linux.

I did a diff of mod_include.c againt 1.2b4 (the last I downloaded)
and nothing appears suspicious.  But it includes the snprintf change
which makes the output pretty big, so I might be missing something.
Does anyone have a 1.2b6 tarball lying around?

Here at least, suexec doesn't seem to have any effect.  There is one
thing I've noticed which might trip up ssi users.  It causes commands
with parameters to fail:
    [23:48:57 07-03-97]: invalid command (/bin/echo hello)
Since we've received some bug reports about other problems handling
this construct, I thought I'd pass it along as a head's up.

--
Howard Fear      I'm just a country perl hacker Jim.        hsf@pageplus.com
                    http://www.pageplus.com/~hsf/           hsf@redcape.com

Mime
View raw message