httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <>
Subject [BUG]: "Type map can't find appropriate document for a language." on Solaris 2.x (fwd)
Date Mon, 24 Feb 1997 20:08:34 GMT

Not acked.

I'm not familiar with map files. Is he just incorrectly adding ".var"
to the URL ?

---------- Forwarded message ----------
Date: Mon Feb 24 11:28:06 1997
Subject: [BUG]: "Type map can't find appropriate document for a language." on Solaris 2.x

Operating system: Solaris 2.x, version: 
Version of Apache Used: 1.2b7
Extra Modules used: Everything but msql and dld.
URL exhibiting problem:

A type map cannot find variants due to language.

Here's a transcript of the headers from my
browser -> muffin (which then goes through a
squid proxy to the server, but I also tested
it with a direct connection and with Lynx from
Solaris 2.6):
> GET HTTP/1.0
> Proxy-Connection: Keep-Alive
> Host:
> Accept-Language: en
> Pragma: no-cache
> User-Agent: Mozilla/3.0Gold (WinNT; I)
> Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, */*
> HTTP/1.1 406 Not Acceptable
> Server: Apache/1.2b7
> Date: Mon, 24 Feb 1997 19:17:37 GMT
> Content-type: text/html
> Connection: close

The type map is currently:
> Content-Language: en
> URI: english.html
> Content-Language: de
> URI: german.html

I've tried it with only one English, and it still
doesn't work.  MultiViews works just fine, as does
selection by type (gif v. jpeg).

I've tar'ed up the entire directory and all our
configs in,
if you want them.  It is possible that I've 
simply missed something in the configuration, but
I'm not sure what.  The srm.conf is almost the
stock one, and I do activate the var handler.

I apologize in advance for not digging through the
code myself; I just wanted to get a quick demo
running.  Gotta go back to the work-for-pay stuff
now (parallel sparse matrix partitioner).  sigh...



View raw message