httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <>
Subject Re: updated status for 1.2b7
Date Sun, 16 Feb 1997 07:16:49 GMT
On Sat, 15 Feb 1997, Jim Jagielski wrote:

> >   * let's fix the Solaris 2.6 and HPUX getwd junk the right way.  
> >     Either get rid of the (one) call to getwd or use ap_getwd and 
> >     #define it appropriately in conf.h
> Ugly to add another new define for all entries in conf.h for one
> use of a call... If no other alternatives, then we should wrap the
> HPUX/Sol2.6 stuff (ie: only their entries in conf.h need be
> adjusted) as needed. I'll look.

The problem is that we will continually have this problem as things
change, etc.  We don't actually have to add a define for all of them, we
could just add a define for those that currently have one then default to
#define ap_getwd getwd for the rest.  

I think it is a lot better to solve namespace conflicts by renaming things
than by continually adding special cases.  

...but I think we could get rid of the one getwd extremely easily anyway,
so that is more worthwhile IMHO...

View raw message