httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chuck Murcko <ch...@Topsail.ORG>
Subject Re: bug with proxy TRACE? (fwd)
Date Fri, 21 Feb 1997 16:19:53 GMT
Sigh. Apache isn't an HTTP/1.1 proxy yet. That's on the punch list for
post-1.2 release, probably 1.2.1. The proxy also needs major cache
performance improvements, which will follow with or just after HTTP/1.1
compliance.

I've had my hands full just getting the proxy to the point where it works.

Thanks for checking, though. Indeterminate results are all you'll get
currently from a TRACE, however.

> ---------- Forwarded message ----------
> Date: Fri, 21 Feb 97 10:33:36 EST
> From: Dave Kristol <dmk@research.bell-labs.com>
> To: apache-bugs@apache.org
> Subject: bug with proxy TRACE?
> 
> I'm running Apache/1.2b3 as a (non-caching) proxy.  I sent it the
> following request with the expectation that it would get forwarded
> to the next-hop server (and so on):
> 	TRACE http://www.apache.org/ HTTP/1.1
> 	Host: www.apache.org
> 
> I got back an immediate non-forwarded response from the proxy itself:
> 
> HTTP/1.1 200 OK
> Date: Fri, 21 Feb 1997 15:26:56 GMT
> Server: Apache/1.2b3
> Transfer-Encoding: chunked
> Content-Type: message/http
> 
> 3c
> TRACE http://www.apache.org HTTP/1.1
> Host: www.apache.org
> 
> 0
> 
> I expected at least two hops (and Via headers) and a response from
> www.apache.org, or a failure from an intervening Netscape proxy.
> 
> Dave Kristol
> 
chuck
Chuck Murcko
chuck@topsail.org

Mime
View raw message