httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: [BUG]: "status report shows PIDs for empty slots" on OTHER:Any (fwd)
Date Wed, 12 Feb 1997 03:07:45 GMT
Rob Hartill wrote:
> 
> 
> I'm not using the status module these days. This sounds like
> something others will at least want to look at.
> 
> Date: Tue Feb 11 17:10:11 1997
> From: stok@pencom.com
> To: apache-bugs%apache.org@organic.com
> Subject: [BUG]: "status report shows PIDs for empty slots" on OTHER:Any
> 
> Submitter: stok@pencom.com
> Operating system: OTHER:Any, version: 
> Version of Apache Used: 1.2b6 + 4 official patches
> Extra Modules used: mod_status
> URL exhibiting problem: http://vrooom.nis.newscorp.com:8008/status
> 
> Symptoms:
> --
> This is just a cosmetic bug, but I find the display
> of a process ID in an empty slot a distraction.
> 

Hmmm... I think the slot is filled with the main httpd's PID

Can't recall if it's required.

I'll take a gander

> The url below points at a modified status output
> which I would like to submit as a patch, you can
> pick up the patch I made against the 1.2b6 source
> at 
> 
> http://vrooom.nis.newscorp.com:8008/mod_status.patch
> 
> I'm not sure whether the buffer size should be declared
> in terms of the size of an int (which the PID is cast to)
> or a pid_t - I'm really a perl hacker - so you may
> want to make sure you're happy with my sizes and
> casts.
> --
> 
> Backtrace:
> --
> 
> --
> 
> 


-- 
====================================================================
      Jim Jagielski            |       jaguNET Access Services
     jim@jaguNET.com           |       http://www.jaguNET.com/
                  "Not the Craw... the CRAW!"

Mime
View raw message