httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <ma...@znep.com>
Subject Re: [BUG]: "1.2b4 hangs computer/connections ending in RST's" on Solaris 2.x (fwd)
Date Wed, 15 Jan 1997 00:08:20 GMT
Sounds like more of the stuff related to lingering close and/or FIN_WAIT_2
stuff.  

The connection reset by peer bit is interesting.  Somewhere the close is
getting screwed up so it gets a RST before a proper FIN?  

I still want to know why the below bit of code from lingering_close() is
using keep_alive_timeout.  What if someone sets it to 0?  I wondered for a
moment if the nokeepalive BrowserMatch bit for Netscape may not have been
doing something with that, but it shouldn't touch the keep_alive_timeout.  

    FD_ZERO (&fds);
    FD_SET (sd, &fds);
    tv.tv_sec = server_conf->keep_alive_timeout;
    tv.tv_usec = 0;


I also would like someone to comment on why the select() below that code
does not have a different effect on Linux than on other platforms, since
AFAIK Linux modifies the value in the timeout (you know, like the BSD man
pages have threatened for years...). 


On Tue, 14 Jan 1997, Rob Hartill wrote:

> 
> ideas ?
> 
> ---------- Forwarded message ----------
> Date: Tue Jan 14 12:25:31 1997
> From: barr@math.psu.edu
> To: apache-bugs%apache.org@organic.com
> Subject: [BUG]: "1.2b4 hangs computer/connections ending in RST's" on Solaris 2.x
> 
> Submitter: barr@math.psu.edu
> Operating system: Solaris 2.x, version: 
> Version of Apache Used: 1.2b4
> Extra Modules used: 
> URL exhibiting problem: 
> 
> Symptoms:
> --
> I realize this is not a very helpful bug report.
> My main reason for reporting it to see if you have
> gotten any other similar reports so I know if
> it indeed may be the problem I suspect.  (i.e.
> I'm not going crazy)
> 
> Within hours after installing 1.2b4, our web
> server began experiencing daily crashes whereby
> all TCP service to the machine would hang.
> You could ping the machine, but not much else.
> 
> Later on I noticed that connections to the web
> server after one of the reboots would all end
> in "Connection reset by peer" after trasmitting
> the file.
> 
> I have backed off to version 1.1.3 and since
> then things have been fine.
> 
> This computer is also current with all the latest
> Solaris patches.  (kernel, tcp, and others).
> 
> It seems likely this is an OS bug that Apache
> is tickling somehow.  (perhaps related to
> the connection resets?)
> --
> 
> Backtrace:
> --
> 
> --
> 


Mime
View raw message