httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason S. Clary" <jcl...@futurefx.com>
Subject how about a mod_dld w/ libdl?
Date Fri, 24 Jan 1997 01:23:15 GMT


I just noticed mod_dld only uses the GNU libdld, which only support a.out
format binaries.  I'm running a 100% ELF system here so it bombs when
I link with libdld...

I've heard someone made an ELF version of libdld, but its supposed to
be much less efficient than libdl...  

I guess from what I've read that libdl is only supported on solaris
and linux, and possibly a few other variant systems, but since
linux is so widely used these days someone might want to write
support for libdl into Apache.

If noone else has one, or noone wants to do it, I'll do it and
send in patches.

Jason S. Clary <jclary@futurefx.com>

Mime
View raw message