httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: [PATCH] "PATH_INFO variable not set when using serverside includes" on Solaris 2.xSolaris (fwd)
Date Wed, 15 Jan 1997 20:41:29 GMT
Rob Hartill wrote:
> 
> 
> +1

+1 as well
> 
> Index: util_script.c
> ===================================================================
> RCS file: /export/home/cvs/apache/src/util_script.c,v
> retrieving revision 1.38
> diff -c -r1.38 util_script.c
> *** util_script.c	1997/01/10 09:34:44	1.38
> --- util_script.c	1997/01/14 05:47:21
> ***************
> *** 243,249 ****
>        * come with the script URI in the include command.  Ugh.
>        */
>       
> !     if (!r->path_info || !*r->path_info || !strcmp (r->protocol, "INCLUDED"))
{
>           table_set (e, "SCRIPT_NAME", r->uri);
>       } else {
>   	int path_info_start = find_path_info (r->uri, r->path_info);
> --- 243,253 ----
>        * come with the script URI in the include command.  Ugh.
>        */
>       
> !     if (!strcmp (r->protocol, "INCLUDED")) {
> !         table_set (e, "SCRIPT_NAME", r->uri);
> ! 	if (r->path_info && *r->path_info)
> ! 	    table_set (e, "PATH_INFO", r->path_info);
> !     } else if (!r->path_info || !*r->path_info) {
>           table_set (e, "SCRIPT_NAME", r->uri);
>       } else {
>   	int path_info_start = find_path_info (r->uri, r->path_info);
> 
> 


-- 
====================================================================
      Jim Jagielski            |       jaguNET Access Services
     jim@jaguNET.com           |       http://www.jaguNET.com/
                  "Not the Craw... the CRAW!"

Mime
View raw message