httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r...@imdb.com (Rob Hartill)
Subject Re: WWW Form Bug Report: "Missing "authuser" (%u) field in common log format if status code is 401" on Solaris 2.x
Date Fri, 03 Jan 1997 00:24:15 GMT

hi,


Mmmm, what you describe looks nasty. I'll forward your mail to the
developers list for more attention.

cheers,
rob

wikne@lynx.uio.no wrote:
>
>Submitter: wikne@lynx.uio.no
>Operating system: Solaris 2.x, version: 
>Version of Apache Used: 1.2b4 (same with 1.1.1)
>Extra Modules used: agent_log, referer_log, status, info
>URL exhibiting problem: 
>
>Symptoms:
>--
>The "authuser" field is blank in common log format
>if authorization is applied, and the remote user
>specifies a password, but leaves UID blank.
>NCSA inserts a "-" here, same as Apache does if
>_both_ password and UID are left blank when a
>protected document is requested.
>Somewhere in the documentation it is mentioned
>that the %u field of customized logging "may be
>bogus" in case of a 401 error. I assume this may
>refer to a situation where a user enters some
>rubbish for a UID. But I see no reason why the
>two above mentioned cases, both with _blank_ UID,
>should be treated differently when applying common
>log format.
>This behaviour is annoying to me, as the missing
>"-" causes some logfile analyzing programs to
>go bananas....
>
>-----------------
>
>Example of offending log file line:
>modem02.artech.se -  [04/Nov/1996:19:45:38 +0100] "GET /jon/gif/girls./ HTTP/1.0" 401
285
>--



Mime
View raw message