httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Behlendorf <br...@organic.com>
Subject Re: WWW Form Bug Report: "probably typo error" on Solaris 2.x
Date Mon, 09 Dec 1996 06:27:24 GMT

This seems correct to me - why didn't this cause noticeable problems earlier?

It's so great to have users who use purify.  :)

	Brian

> andy@demos.net wrote:
> >
> >Submitter: andy@demos.net
> >Operating system: Solaris 2.x, version: 
> >Version of Apache Used: 1.1.1 and 1.2b1
> >Extra Modules used: mod_status
> >URL exhibiting problem: 
> >
> >Symptoms:
> >--
> >In for() one could miss '*', so we compare the address
> >(pointer) not the array element value:
> >
> >*** http_protocol.c.orig        Wed Dec  4 18:57:19 1996
> >--- http_protocol.c     Wed Dec  4 18:57:39 1996
> >***************
> >*** 411,417 ****
> >  #endif
> >  
> >  /* A proxy request contains a ':' early on, but not as first character */
> >!     for (s=uri; s != '\0'; s++)
> >        if (!isalnum(*s) && *s != '+' && *s != '-' && *s
!= '.') break;
> >  
> >      if (*s == ':' && s != uri)
> >--- 411,417 ----
> >  #endif
> >  
> >  /* A proxy request contains a ':' early on, but not as first character */
> >!     for (s=uri; *s != '\0'; s++)
> >        if (!isalnum(*s) && *s != '+' && *s != '-' && *s
!= '.') break;
> >  
> >      if (*s == ':' && s != uri)
> >
> >--
> >
> >Backtrace:
> >--
> >
> >--
> >
> 
> 
> -- 
> Rob Hartill.       Internet Movie Database Ltd.    http://www.imdb.com/  
> 

--=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=--
brian@organic.com  www.apache.org  hyperreal.com  http://www.organic.com/JOBS


Mime
View raw message