httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <r...@imdb.com>
Subject Re: WWW Form Bug Report: "'cut' not available on all platforms" on NeXT
Date Tue, 03 Dec 1996 16:09:08 GMT

Thanks for the information.

clu@malihh.high-performance.de wrote:
>
>Submitter: clu@malihh.high-performance.de
>Operating system: NeXT, version: 3.0
>Version of Apache Used: 1.2b1
>Extra Modules used: php
>URL exhibiting problem: 
>
>Symptoms:
>--
>In the helpers/GuessOS and helpers/CutRule you
>use the UN*X 'cut' tool. This is not available
>on all plattforms, espcially  not on BSD4.3ish
>systems. One can easily replace it by awk which
>is much more portable and much more slower.
>
>e.g. cut -d= -f2
>
>becomes awk 'BEGIN {FS="="}{print $2}'
>
>as you of course know.
>
>
>--
>
>Backtrace:
>--
>
>--
>


-- 
Rob Hartill.       Internet Movie Database Ltd.    http://www.imdb.com/  

Mime
View raw message