httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <>
Subject Re: src/README
Date Sun, 01 Dec 1996 22:26:03 GMT
Brian Behlendorf wrote:
> The current README in the src directory is a tad dated, but still very valuable
> information about the code structure and philosophy behind Rob Thau's massive
> revamp work around the time of 0.8 and 1.0.  I'm all for keeping it around, but
> I'd like to add an introductory note, and change the name from README to
> something a little more explanatory, like CODE_STRUCTURE or something.  The
> intro would be something along the lines of:
> ###
> [The following document was written by Robert S. Thau ( on the
> release of Apache 1.0.  Some details may have changed since then regarding the
> functions and names of modules, but the basic ideas are still intact.]

The #define's stuff I added to the end of it is pretty useful, and
is much closer to 1.1.1/1.2 than 1.0 (assuming you mean ./src/README).

I'm all for moving that kind of stuff to a ./src/PORTING file, which I
am working on but won't be done for 1.2

      Jim Jagielski            |       jaguNET Access Services           |
                  "Not the Craw... the CRAW!"

View raw message