httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy T. Fielding" <field...@liege.ICS.UCI.EDU>
Subject escape_uri bug fix never applied
Date Tue, 26 Nov 1996 09:28:08 GMT
Here's another one.

.....Roy

------- Forwarded Message

From: rasmus@madhaus.utcs.utoronto.ca
Date: Thu, 28 Mar 1996 17:57:01 -0500 (EST)
Subject: Re: escaping double-quote
To: new-httpd@hyperreal.com
In-Reply-To: <9603281305.aa10974@paris.ics.uci.edu>
Message-ID: <ML-2.0.828053821.1541.rasmus@krone.house.mil>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; CHARSET=US-ASCII
Sender: owner-new-httpd@hyperreal.com
Precedence: bulk
Reply-To: new-httpd@hyperreal.com

> Martijn Koster just mentioned to me that Apache is not escaping
> the double-quote character <"> in URLs.  I'll check for it later
> (I'm too sleepy now anyway), but I thought I'd mention it here so
> that I don't forget when I wake up.  :)

Hmm..  You are right.  This patch should take care of it:

*** util.c	Thu Mar 28 03:00:15 1996
--- util.c.new	Thu Mar 28 17:52:15 1996
***************
*** 847,851 ****
              
      for(x=0,y=0; uri[x]; x++,y++) {
!         if (ind (":% ?+&",(copy[y] = uri[x])) != -1) {
              c2x(uri[x],&copy[y]);
              y+=2;
--- 847,851 ----
              
      for(x=0,y=0; uri[x]; x++,y++) {
!         if (ind (":% ?+&\"",(copy[y] = uri[x])) != -1) {
              c2x(uri[x],&copy[y]);
              y+=2;


------- End of Forwarded Message


Mime
View raw message