httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <r...@imdb.com>
Subject Perhaps a bug? (fwd)
Date Thu, 03 Oct 1996 19:51:44 GMT

Not acked.

Do virtual hosts work with inetd ?  sounds like a recipe for disaster.



----- Forwarded message from Jose Luis Carretero Garcia -----

Date: Thu, 3 Oct 1996 20:23:46 GMT
Message-Id: <199610032023.UAA25476@pizarro.unex.es>
X-Sender: billy@pizarro.unex.es
X-Mailer: Windows Eudora Light Version 1.5.2
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
To: apache-bugs@mail.apache.org
From: Jose Luis Carretero Garcia <billy@unex.es>
Subject: Perhaps a bug?


        Dear Sirs:

        I've got my binary copy of your Apache v1.1.1 httpd server. After a
successuful instalation (with correct responses to my principal www server),
I tried to configure the httpd server for VirtualHosting support. I've tried
in many ways, looking your documentation and advises, without fast success.
My OS is Solaris 2.5.1, running in a Sparc IPC with 24 MB of memory and 1 GB
of hard disk. I've got one qualified dns server name too, and I wanted to
include a response for a new known IP address.

        - First time, I tried to use your new feature of virtualhosting,
letting access         to two different IP addresses without taking care of
multiIP interfaces. Doesn't         work.

        - Second time, I openen the inetd new http channel, and configure
your server as         inet type. I opened too, the second le0 interface
with the new IP address. When         I uncommented the Virtual hosting
section (sure correctly configured and after          rebooting the system),
server went down and produced our friendly core file.

        - Third time, I tried with the multi daemons option. With my port 80
service, 
        and my recently created http channel in inetd.conf, the server still
created the         core file. Of course, I had two different copies of your
server in my hd,         running into separate inet channels.

        - Fourth time, I tried with different port's numbers. And it worked,
but merging         data from one to another service.

        - At last, I've the server working in the two interfaces with the
multidaemons          option, and standalone option for two of them. With
different BindAddress               directives.

        So, finally, I think that VirtualHosting, in Solaris 2.5.x and using
inetd server types, doesn't work correctly. Perhaps I unknown something that
I must known, but here is my report, for you to take in mind. 

        Best regards, I hope you go on with your good work,





                                                Jose Luis Carretero Garcia
                                                Center of Remote Sensing and GIS
                                                Dp. of Geography & Regional
Planning
                                                UNIVERSITY OF EXTREMADURA
        

        


----- End of forwarded message from Jose Luis Carretero Garcia -----

-- 
Rob Hartill (robh@imdb.com)    
http://www.imdb.com/  ... why wait for a clear night to see the stars?.

Mime
View raw message