httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@gonzo.ben.algroup.co.uk>
Subject Re: FastCGI and SSL.
Date Tue, 20 Aug 1996 10:27:42 GMT
Michael Smith wrote:
> 
> Has anybody else out there tried to use fastCGI and SSL in apache?  I
> don't see any reasons why it shouldn't work together but I'm having
> trouble.  I managed to compile apache with fastCGI and SSL support
> without any trouble (fastCGI first in the Configuration file).

I believe that FastCGI bypasses Apache's I/O, which means it can't be used with
SSL without modification. I could be wrong, though...

Cheers,

Ben.

> 
> It runs without errors, and non-fastCGI pages appear as they should. 
> But when I try to access a fastCGI page, the browser gives me the
> following error:
> 
> SSL has received a record with an incorrect Message Authentication
> Code.  This could indicate a network error, a bad server implementation,
> or a security violation.
> 
> I get various random characters appearing in the browser window.  In the
> ssl.log file I get (not sure if this is relevant) "CIPHER is
> EXP-RC4-MD5". 
> 
> If anybody else has got these modules to work together, please let me
> know - or if anybody has any good ideas what I should do.
> 
> Thanks for any words of wisdom
> 
> Michael Smith

-- 
Ben Laurie                  Phone: +44 (181) 994 6435
Freelance Consultant and    Fax:   +44 (181) 994 6472
Technical Director          Email: ben@algroup.co.uk
A.L. Digital Ltd,           URL: http://www.algroup.co.uk
London, England.            Apache Group member (http://www.apache.org)

Mime
View raw message