httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@engelschall.com (Ralf S. Engelschall)
Subject ErrorDocument problem under 1.2-dev
Date Wed, 21 Aug 1996 10:02:10 GMT

Recently while testing mod_rewrite v2.2-SNAP with Apache 1.2-dev I discovered
that the ErrorDocument feature under 1.2-dev was broken in some way. I had a
404-ErrorDocument (file not found) which get correctly called and executed
under 1.1.1 while under 1.2-dev the server complains: "No object data" or
such a message.

In the past I always though that this is a subtle bug in mod_rewrite which
causes this. Now I traced this problem again and discovered that it has
nothing to do with mod_rewrite.

Alexei tested it also and for him ErrorDocuments worked. The reason why the
problem only occured for me are the following:

I used a very special 404-ErrorDocument which was a NPH script, because in
the old days we installed .redir files which could redirect the browser to
the new location if an obsolete files cannot not found (now in the days of
mod_rewrite you just but a rule in your .htaccess file!). This only worked
with NPH scripts in the past, so my 404-ErrorDocument was of this type.
Under 1.1.1 this works fine. Under 1.2-dev it still doesn't any more!

I now changed it back to a standard CGI-script and now it works for 1.2-dev,
too!

The only question left is: Is NPH for ErrorDocuments totally obscure and ok
that from 1.2 up it will never work (while is really worked under 1.1.1) or
is this a bug in 1.2 (perhaps its mod_cgi.c) which should be fixed?

Greetings,
                                        Ralf S. Engelschall    
                                        rse@engelschall.com
                                        http://www.engelschall.com/~rse

Mime
View raw message