httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: Netscape and Keepalives
Date Thu, 15 Aug 1996 20:54:14 GMT
Alexei Kosut wrote:
> 
> On Thu, 15 Aug 1996, Jim Jagielski wrote:
> 
> > Maybe I'm seeing something different then... When I access some pages
> > served by 1.2-dev using Netscape, occasionally Netscape will just
> > "hang" for few/several seconds before it reports Done. No additional
> > updating is done during this period (if I hit Stop, the page is the
> > same as it would be if I let NS continue)... Doesn't happen at all
> > with MIE.
> > 
> > Is this one symptom of the keepalive problem?
> 
> This is the symptom of a different keepalive problem with Netscape. Are
> these pages very small (under 1024 bytes) and are you on a fast local
> network? If so, you may be running into the problem where if Navigator
> reads the entire body of the entity in the same read as the headers, it
> won't recognize keepalive status. We added the fflush() to stop this from
> happening, but on a very fast network, it still can sometimes.
> 

Yep... I did trace it back to the Netscape hack, which still occurs.

Now that we have BrowserMatch, I'll try that out. I've also discovered
that reducing KeepAliveTimeout helps out as well.


-- 
Jim Jagielski  << jim@jaguNET.com >>   |   "There is a time for laughing,
  **  jaguNET Access Services  **      |    and a time for not laughing,
      Email: info@jaguNET.com          |    and this is not one of them"
++    http://www.jaguNET.com/         +++      Voice/Fax: 410-931-3157       ++

Mime
View raw message