httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexei Kosut <ako...@organic.com>
Subject Re: RegExp stuff to be included in 1.2?
Date Tue, 23 Jul 1996 18:23:33 GMT
On Tue, 23 Jul 1996, Ralf S. Engelschall wrote:

> I for myself would say: rx-1.0 from GNU, but that should not count.  But if
> there is still no final answer, I will give you some more hints about
> available versions.

Hmm. I took a look at rx, and it seems rather large - 2/3 the size of
Apache itself, and five times the size of, for example, Spencer's
POSIX-compatible package (the one you reference at
ftp://zoo.toronto.com/pub/regex.shar). Except when I compile that, I get
a lot of "warning: integer overflow detected: op "<<"" errors (native cc,
Solaris 2.5).

I guess I could be convinced to use rx. Except that it uses autoconf, and
since we don't (yet), that could be a problem. As well, I'm not sure if we
could use GPLed software with the current Apache license. Does anyone
know?

Whichever package we use, I think we'd have to do some rearranging of the
source and header files, probably write a new makefile to work with
Apache's. Blah.

*sigh*

-- Alexei Kosut <akosut@organic.com>            The Apache HTTP Server 
   http://www.nueva.pvt.k12.ca.us/~akosut/      http://www.apache.org/


Mime
View raw message