httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ras...@madhaus.utcs.utoronto.ca
Subject Re: Binaries for 1.1
Date Tue, 02 Jul 1996 13:18:19 GMT
> On Mon, 1 Jul 1996, Randy Terbush wrote:
> > BTW - No response to my question about whether we need to create
> > Solaris 2.5 binaries, and if so shall I?
> 
> I don't *think* there should be much difference - I'll actually be
> building 2.5, not 2.4, at any rate.  I am more concerned about sunos 4.1.3
> vs. 4.1.4 - building both might be a good idea, as well as HPUX 9 and 10
> if we can.

Be careful here.  Solaris 2.4 binaries will run on 2.5, but the reverse
is not always the case since Sun brilliantly decided to stick a bunch of
BSD-style functions into the Solaris 2.5 libc.  If you are careful and make
sure that the binary does not contain any calls to bzero(), bcopy(), bcmp()
and such, then you can safely build the binary on Solaris 2.5 and have it
work on 2.4 boxes.

I have been bitten by this one a couple of times now, so I am very aware 
of it.

-Rasmus

Mime
View raw message