httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Behlendorf <br...@organic.com>
Subject Re: WWW Form Bug Report: "Problems with keep-alive" on HPUX
Date Mon, 10 Jun 1996 22:53:22 GMT

> >Submitter: djg@tas.com
> >Operating system: HPUX, version: 9.01
> >Version of Apache Used: 1.1b3
> >Extra Modules used: 
> >URL exhibiting problem: 
> >
> >Symptoms:
> >--
> >Just a couple of minor problem.  
> >
> >If you are using virtual servers the keepalive and
> >keepalivetimeout must be specified for the virtual servers
> >if you want the non default values.  If you specify them
> >outside the virtual server section of the config files
> >they are not used for the virtual servers.

This should be fixed in 1.1b3, which was just released this morning.  
Check it out and let us know.

> >If you are using a proxy-server which doesn't understand
> >keep-alive so it passes it through from the browser you get 
> >large delays on loading pages.  I have this problem with X 
> >Mosaic 2.7b2 and Cern proxy server.
> >
> >I added a user_agent check to set_keepalive to fix this
> >for our configuration.

We'll check with our "HTTP Cop", but I thought the mechanism was
old-proxy-safe... arg.  If it's not, this is probably an appropriate fix,
though I would throw in a check for the version of the CERN proxy just to not
eliminite the possibility of this being fixed. 

	Brian

--=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=--
brian@organic.com  |  We're hiring!  http://www.organic.com/Home/Info/Jobs/


Mime
View raw message