httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Skolnick <cl...@organic.com>
Subject WWW Form Bug Report: "Problems w/.htaccess in cgi-bin directory." on Solaris 2.x (fwd)
Date Tue, 28 May 1996 19:04:53 GMT

Can someone help this guy out?  I have no spare cycles for the next 
coupel days.

--
Cliff Skolnick                                      cliff@organic.com

"They that can give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety." -- Benjamin Franklin, 1759

---------- Forwarded message ----------
Date: Tue May 28 5:16:43 1996
From: mowgli@ace.sprawl.com
To: cliff@organic.com
Subject: WWW Form Bug Report: "Problems w/.htaccess in cgi-bin directory." on Solaris 2.x

Submitter: mowgli@ace.sprawl.com
Operating system: Solaris 2.x, version: 
Version of Apache Used: 1.0.5
Extra Modules used: (Standard modules)
URL exhibiting problem: 

Symptoms:
--
Basically, a .htaccess file which works fine in
user space (document area) doesn't seem to work
at all in the cgi-bin directory. I've configured
the cgi-bin directory in access.conf with the
AllowOverrides All, but that doesn't help either.

When given the .htaccess file below, authorization
*always* fails, with no information at all in
the error log. It's either a bug that the .htaccess
file isn't working in the cgi-bin directory, or
(and?) it's a bug that authorization failures
don't seem to be logged anywhere.

Here's the .htaccess file. It works fine in a
document directory, just not in the cgi-bin
directory :

Options All
AuthType Basic
AuthName Sprawl Production Page
AuthUserFile /usr/local/etc/security/production.passwd
AuthGroupFile /usr/local/etc/security/production.group
<Limit GET>
  require user mowgli visiting
</Limit>
			Thanks, <Mowgli>

PS. This occurs both under Linux & Solaris, and
    also occurred when someone moved their .6x?
    Apache setup to the new version, 1.0.5.
--

Backtrace:
--

--


Mime
View raw message