httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@gonzo.ben.algroup.co.uk>
Subject Re: Apache on OSF/1
Date Thu, 02 May 1996 15:00:13 GMT
Richard Freilich wrote:
> 
> On Thu, 2 May 1996, Ben Laurie wrote:
> 
> > Richard Freilich wrote:
> > > 
> > > 
> > > I recently installed Apache 1.0.5 on a DEC Alpha Station 1000 running
> > > OSF/1 3.2c, switching from a Compaq 486 DX2/66 running BSDi.  For some
> > > reason, about once a day, I need to kill the Apache server and restart it,
> > > as I cease to get a response from it.  Anybody know of any reason(s) why
> > > this would be happening?
> > > 
> > > One new error I'm noticing in the logs is this:
> > > 
> > > application-specific initilization failed: error getting working directory
> > > name: permission denied
> > > 
> > > Also quite a number of SIGSEGV errors.
> > > 
> > > Any information on why this is happening would be helpful, thanks.
> > 
> > Could this be the mod_dir buffer overrun bug? (Guys, we really should fix this
> > and release 1.0.6!).
> 
> Would this bug not have also acted up on my BSD box?

Well, it potentially corrupts 1 byte of stack so exactly what happens is very
dependent on the machine/compiler/direction of wind.

Cheers,

Ben.

> 
> Richard
> 

-- 
Ben Laurie                  Phone: +44 (181) 994 6435
Freelance Consultant and    Fax:   +44 (181) 994 6472
Technical Director          Email: ben@algroup.co.uk
A.L. Digital Ltd,           URL: http://www.algroup.co.uk
London, England.

Mime
View raw message