httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <r...@imdb.com>
Subject Re: WWW Form Bug Report: "web server sleeps" on FreeBSD
Date Thu, 30 May 1996 19:06:09 GMT

>Submitter: sjohn@www.alamak.com
>Operating system: FreeBSD, version: 2.1
>Version of Apache Used: 1.05
>Extra Modules used: used default
>URL exhibiting problem: http://www.alamak.com/chat/index.html
>
>Symptoms:
>--
>The web server goes to sleep and will not accept
>connections. There are a couple different things
>that seem to trigger it. In some cases it is clearly
>that the server has reached MAX_PID and the child
>httpd processes are split between low and high and it
>seems to go to sleep.
>
>But, randomly I get there errors on the console and
>these are associated with a more severe sleep up to
>10 minutes or more....
>
>Here is an example of the errors that I am getting
>from httpd ...
>
>May 30 11:46:40 www httpd: gethostby*.gethostanswer: asked for "96.98.10.206.in-addr.arpa",
got "96.0.98.10.206.in-addr.arpa"
>   
>May 30 11:47:11 www httpd: gethostby*.gethostanswer: asked for "96.98.10.206.in-addr.arpa",
got "96.0.98.10.206.in-addr.arpa"
>May 30 11:48:18 www last message repeated 2 times

your mail will be shown to the developers. If anyone wants to comment on
the above they'll be in touch soon.

>I'm to the greatest unix expert so I'd appreciate
>any help you can offer.

I'm no expert either, but what you say below, is wrong.

>For the first case I tried increasing the max pid
>allowed in the kernel but found cron didn't like
>that ... it is set ridiculously low 30,000 which
>I reach that value in less than an hour at the rate
>of turnover on my server. I may try recompiling
>cron with a higher max_pid with the kernel and see
>to fix that but what is the inet.arpa stuff that
>httpd is sending as error to the console? The
>strange thing is that it seemed to have little 
>effect on my other server which is a P133 ... but
>the new one I am having problems with gives the 
>same error but seems to have these terrible sleeps...
>the new server is a Pentium-Pro so different cpu
>architecture ... should i turn of the -m486 flag
>whem compiling?

pid's wrap around to the lowest free pid once they reach the
max. You should put the number back to where it was originally.

It's possible that you are running low on some other resource such
as processes per user, file descriptors or network buffers.

Long delays are often caused by the nameserver. If you have namelookups
switched on (addresses instead of numbers appearing in the logs) then
switch it off by setting MIMIMAL_DNS in "Configuration" then recompiling
apache.


rob

Mime
View raw message