httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aram Mirzadeh <...@qosina.com>
Subject Re: FastCGI + Linux + Apache 1.1?
Date Mon, 13 May 1996 01:02:08 GMT
> 
> Well, I finally got FastCGI working with Apache/1.1b3 and Linux 1.99.1.
> There are a couple of tricks.  I will post some patches later when
> I get things cleaned up.  The two main problems are that the server
> core dumps if a .fcgi file isn't found, and more problematic, the Unix
> domain socket is created by the parent httpd which runs as root.  When the
> child httpd processes that run as nobody try to connect they get a
> permission denied error.  I currently fixed it by simply doing a chown nobody
> on the socket.

You're really bad with version numbers aren't you?  :) 

Anyway I got it working as well, but I can't get it to get to run any of the
fcgi files... as soon as I run any of them, the main server dumps core and
I get a ton of zombie processes.   

Also, did you ever get a chance to test apache under libc 5.3?  I'm still
getting reports with core dumping and libc 5.3. 

I can't upgrade any of my systems right now. 

<Aram>

-- 
Aram Mirzadeh						awm@qosina.com
MIS Manager				      Apache httpd team member
Qosina Corporation				    aram@hyperreal.com
http://www.qosina.com/			    http://www.qosina.com/~awm

You're not drunk if you can lie on the floor without holding on.
                -- Dean Martin


Mime
View raw message