httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Skolnick <cl...@organic.com>
Subject WWW Form Bug Report: "Bugs in mod_imap.c" on Solaris 2.x (fwd)
Date Wed, 20 Dec 1995 18:36:40 GMT


For the map edit folk...no reply sent...


---------- Forwarded message ----------
Date: Wed Dec 20 1:47:21 1995
From: jj@sunsite.ms.mff.cuni.cz
To: cliff@organic.com
Subject: WWW Form Bug Report: "Bugs in mod_imap.c" on Solaris 2.x

Submitter: jj@sunsite.mff.cuni.cz
Operating system: Solaris 2.x, version: 
Extra Modules used: mod_charset
URL exhibiting problem: 

Symptoms:
--
If you don't specify any default in a .map file,
then sometimes you get the correct answer (SERVER_ERROR),
but often you get a reference to garbage.
This is because in imap_handler the mapdflt is
not initialized to "", so that if no default overrides
it, sometimes you get non-NUL character at *mapdflt.
Fix is just adding *mapdflt=0; as one of the first lines
in imap_handler. Also, in set_redirect the line
else if (*base_uri) {
should say
else if (*base_uri && *mapurl != '/') {
, since absolute URLs shouldn't have (I think),
base_uri prefixed to them, so that you'll be
able to reference an absolute location on your server.
These things are fixed in my charset.patch, which I would like
to submit soon. Unfortunately, there was no reply to my previous
posting of this patch in new-httpd@apache.org :(
Could you please tell me, where can I upload it to,
so that someone will see it?
--

Backtrace:
--

--


Mime
View raw message