httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexei Kosut <ako...@nueva.pvt.k12.ca.us>
Subject Re: bug in a contrib module (fwd) [1 of 3]
Date Tue, 05 Dec 1995 04:15:04 GMT
On Mon, 4 Dec 1995, Rob Hartill wrote:

> no ack sent.
> 
> Can whoever is responsible send an ack.

I'm responsible for mod_actions, I'll send an ack.

> this is the first of 3 messages I'm going to forward on this
> subject.

The third one was on mod_auth_msql, which isn't mine. Someone else can 
take that.

> > Basically, the code does not test for NULL return from table_get(), which
> > results in a segfault if you do not define an Action for a given directory.
> > This is a very bad error...

He doesn't say what machine/compiler/etc, he is using (I'll ask him in his
email), but it works fine for me. What his code does (the second version)
is to basically replace a !strcmp(..., NULL) with !(...), where ... is a
*char from a table_get. I think I'll end up using his version, beacuse
it's more compact, but is there any reason the former would result in a
seg fault? On my HP-UX 9.04 box, I can run Apache + mod_actions without
any Action directives anywhere, and it works fine... can anyone
confirm/deny this? 

--/ Alexei Kosut <akosut@nueva.pvt.k12.ca.us> /--------/ Lefler on IRC
----------------------------/ <http://www.nueva.pvt.k12.ca.us/~akosut/>
The viewpoints expressed above are entirely false, and in no way
represent Alexei Kosut nor any other person or entity. /--------------



Mime
View raw message