httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexei Kosut <ako...@nueva.pvt.k12.ca.us>
Subject Re: ~user notation stopped working (fwd)
Date Mon, 04 Dec 1995 22:13:10 GMT
On Mon, 4 Dec 1995, Rob Hartill wrote:

> Wasn't this discussed earlier?

I believe so, yes...

> 
> I'll tell him to move to 1.0 and to expect a reply if there's
> an explanation or fix...
*snip*

> > I just upgraded from NCSA 1.3 to Apache 0.8.14, and now "~user/" is no longer
> > working.  I have the following Alias commands in my srm.conf file, and the
> > /users/user notation works, but ~user doesn't:
> > 
> > Alias /~ /home/web/
> > Alias /users/ /home/web/
> > 
> > This is on my home system at http://www.rdrop.com/

Yes, people like the /~ thing, but it isn't consistent with the way 
Aliases work in Apache. One note is that the new mod_userdir I'm working 
on will be able to use "UserDir /home/web" to do what this person is 
trying to do above.

Note that "Alias /~ /home/web" has a possible security problem - going to 
"/~/" will give you a listing of all the directories in /home/web. This 
is not usually something you want.

Also, is it yet time where we can submit feature enhancements for Apache? 
I've a couple sitting here, waiting...

--/ Alexei Kosut <akosut@nueva.pvt.k12.ca.us> /--------/ Lefler on IRC
----------------------------/ <http://www.nueva.pvt.k12.ca.us/~akosut/>
The viewpoints expressed above are entirely false, and in no way
represent Alexei Kosut nor any other person or entity. /--------------



Mime
View raw message