httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <hart...@ooo.lanl.gov>
Subject Re: Apache 0.8.11/Linux Trouble (fwd)
Date Tue, 05 Sep 1995 13:23:46 GMT

>From Andy.

> Date: Tue, 5 Sep 95 19:43:04 BST
> From: Andrew Wilson <andrew@tees.elsevier.co.uk>
> Message-Id: <9509051843.AA10670@tees.elsevier.co.uk>
> To: hartill@hyperreal.com, andrew@tees.elsevier.co.uk
> Subject: Re: Apache 0.8.11/Linux Trouble (fwd)
> Status: RO


Rob my mail from my new address as andrew@tees.elsevier.co.uk is being
refused by new-httpd, can you forward this for me?

> >   Dear Sir(s),
> > 
> >   I seem to compile 0.8.11 OK, but it does not run, not even as root.
> > I have tried every trick there is, but the bugger just will not run.
> > I am running Linux 1.3.23 on a DEC Venturis 486/66 (not that the machine
> > matters), so the Linux kernel is experimental (but that should not
> > matter either). I have tried it on several Linux platforms, several
> > kernel versions, and still: nothing happens when I try to run it.

Apache is simply apalling when it comes to checking the return value of
system calls.  Yesterday I ported our web development tools to solaris 2.4
and messed up some directory file perms.  Apache was unable to write the
httpd.pid file, but still proceeded to seem as if it had detached
sucessfully.  'ps' revealed no running processes, there were no errors in
the error_log (which it didn't have write access to either) but there were
absolutely no clues forthcoming.

I worked out what was happening after 5 minutes of head scratching but I
*KNOW* what I'm doing.  God knows how unlepful this program could be for a
first timer.  Ah well, something for me to do this weekend.

> >   What could this problem be? I get no error messages (even to stderr),
> > I have configured everything by the book (I have been installing and
> > administrating NCSA servers for almost two years now; one commercial
> > effort can be found @ http://www.kiss.fi/; sorry, it's in finnish only),
> > and still, nought. *sigh* What is a fellow to do with this kind of a
> > problem?


Mime
View raw message