httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chuck Murcko <ch...@telebase.com>
Subject Re: bugs and design/build issues in Apache 0.8.1x (fwd)
Date Wed, 13 Sep 1995 03:18:22 GMT
Hmmm. A stock Linux compile 0f 0.8.13 (NOT using dbm libraries) builds fine
here under Linux 1.2.9. I use Configure to generate the Makefile. I can only
guess he was trying to build the dbm_auth_module or something. Or, I suspect,
Linux is changing rapidly.

I did get a bunch of warnings about LITTLE_ENDIAN being redefined and I get
no warnings at home under the 'ancient' Linux 1.2.5. The includes in Linux
seem to be getting more deeply nested, and duplicates are popping up.

Aram W. Mirzadeh liltingly intones:
> 
> 
> If anyone can translate this to english please send me a copy. 
> 
> Thank you.
> 
> <Aram>
> 
> 
> At 03:18 PM 9/12/95 MDT, you wrote:
> >
> >According to this guy, the standard Makefile doen't set the right
> >defaults for Linux, and neither does the Configuration file.
> >
> >I think that's what he's getting at.
> >
> >> From: andy@distrib.com (Andrew Cromarty)
> >> Subject: Re: bugs and design/build issues in Apache 0.8.1x
> > 
> >> We needn't beat a dead horse about the Makefile issue, but to answer your 
> >> questions:
> >> 
> >> - I followed the directions, and thus did not use Configure.  The INSTALL
> >>   file leads the user away from using Configure unless you want to
> >>   add new modules:
> >> 
> >> 	"If you are satisfied with our standard module set, and expect to
> >> 	continue to be satisfied with it, then you can just edit the stock
> >> 	Makefile and compile as you have been doing previously.  If you would
> >> 	like to select optional modules, however, you need to run the
> >> 	configuration script."
> >> 
> >> - Neither the Makefile nor the Config* files set the -ldbm load option with
> >>   the other LINUXs options, nor document it as required specifically by
> LINUX.
> >>   My suggestion was: adding this line to Configuration in the LINUX
> >>   section probably is easier for you than answering 100's of questions
> >>   about "why apache doesn't link under Linux."  Your time, your choice....
> >>   Note also that the Makefile provided with 0.8.13 apparently was not 
> >>   produced by the current version of Configure and Configuration.
> >> 
> >> No need to reply to me on the above.
> >
> >
> --
> Aram W. Mirzadeh, MIS Manager, Qosina Corporation
> http://www.qosina.com/~awm/, awm@qosina.com
> Apache httpd server team http://www.apache.org
> 
> 
> 

chuck
Chuck Murcko	Telebase Systems, Inc.	Wayne PA	chuck@telebase.com
And now, on a lighter note:
Give me a Plumber's friend the size of the Pittsburgh dome, and a place
to stand, and I will drain the world.

Mime
View raw message