httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Hartill <hart...@hyperreal.com>
Subject Bug in 0.8.10 and 0.8.8 : multiple //// with cgi-scripts (fwd)
Date Sun, 20 Aug 1995 17:42:06 GMT
Forwarded message:
> From s.oosthoek@student.utwente.nl  Sun Aug 20 02:35:14 1995
> Message-Id: <199508200935.AA26869@student.utwente.nl>
> Date: Sun, 20 Aug 95 11:35:08 0200
> From: Simon Oosthoek <s.oosthoek@student.utwente.nl>
> X-Mailer: Mozilla 1.2b5 (Windows; I; 32bit)
> Mime-Version: 1.0
> To: apache-bugs@apache.org
> Subject: Bug in 0.8.10 and 0.8.8 : multiple //// with cgi-scripts
> Content-Transfer-Encoding: 7bit
> Content-Type: text/plain; charset=us-ascii
> 
> Hello People,
> 
> I have very recently started using the apache web-server (first 0.8.8, now 
> 0.8.10).
> 
> I have noticed that unlike ncsa, multiple slashes are converted nicely to a 
> single /, however that doesn't go for cgi-scripts.
> I use a line like this:
> 
> <IMG 
> SRC="cgi-bin/nph-count?width=5&link=http://cal003109.student.utwente.nl/ind
> ex.html">
> 
> if I call the page with http://cal003109.student.utwente.nl////tmp.html the 
> counter shows up in the error_log:
> 
> [Sun Aug 20 11:18:47 1995] access to /WWW/httpdocs////cgi-bin failed for 
> cal003105.student.utwente.nl, reason: File does not exist
> 
> but only the counter, everything else is fine!
> 
> I hope you can do something with this info.
> 
> anyway, thanks for sharing apache with the world!
> 
> Simon
> 
> (the system is a 398dx33 (8MB) with linux (slackware) 1.2.11
> if you need more details, just ask.)
> 
> 
> 


Mime
View raw message