httpd-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Behlendorf <br...@organic.com>
Subject Re: HTTP/0.9 - still needed?
Date Tue, 02 May 1995 20:17:07 GMT
On Sun, 30 Apr 1995, Simon Spero wrote:
> On Sat, 29 Apr 1995, Brian Behlendorf wrote:
> > 
> > I'm going to use this to track the user-agents that don't claim to be
> > "HTTP/1.0" compliant in the first line of the request, yet still give a
> > "User-Agent" field, on hotwired and hyperreal - hopefully we'll get a 
> 
> You can't look at the headers in an HTTP 0.9 request - there aren't any! 

True, if this is a valid HTTP/0.9 request.  But my thesis is that there 
are some browsers out there who are really HTTP/1.0 browsers and not 
stating it.  And I was validated - all the following browsers do not send 
"HTTP/1.0" in at least some of their requests:

AIR_Mosaic(16bit)/v3.10.06.07
AIR_Mosaic(16bit)/v1.00.198.07
IBM WebExplorer /v950331 Beta
Lynx/2.3 BETA  libwww/2.14
Lynx/2.3.6 BETA  libwww/2.14
Lynx/2.3.7 BETA  libwww/2.14
Lynx/USiS Lynx 2.3  libwww/2.14
Lynx/ALynx_2.3 AmigaPort 1.13  libwww/unknown
MacWeb/1.00ALPHA3  libwww/2.17
Mozilla/0.96 Beta (Windows)
Mozilla/1.0N (Windows)
Mozilla/1.1b3 (Macintosh; I; 68K)
NetManage Chameleon Mosaic+ 4.03

Uh.....

	Brian

--=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=--
brian@organic.com  brian@hyperreal.com  http://www.[hyperreal,organic].com/


Mime
View raw message