httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cove...@apache.org
Subject svn commit: r1826585 - /httpd/test/framework/trunk/t/apache/http_strict.t
Date Mon, 12 Mar 2018 19:05:41 GMT
Author: covener
Date: Mon Mar 12 19:05:41 2018
New Revision: 1826585

URL: http://svn.apache.org/viewvc?rev=1826585&view=rev
Log:
don't depend on need_min_apache_ver

Sorry, when I added this, it magically just used the Apache::test
in my svn:external.  Now I can't get it to work on another system.

The goal was to keep old releases and old maintenance levels testable


Modified:
    httpd/test/framework/trunk/t/apache/http_strict.t

Modified: httpd/test/framework/trunk/t/apache/http_strict.t
URL: http://svn.apache.org/viewvc/httpd/test/framework/trunk/t/apache/http_strict.t?rev=1826585&r1=1826584&r2=1826585&view=diff
==============================================================================
--- httpd/test/framework/trunk/t/apache/http_strict.t (original)
+++ httpd/test/framework/trunk/t/apache/http_strict.t Mon Mar 12 19:05:41 2018
@@ -119,7 +119,9 @@ my @test_cases = (
       have_module qw(mod_headers) ],
 );
 
-my $test_fold = need_min_apache_fix("2.2.33", "2.4.26", "2.5.0");
+my $test_fold = defined(&need_min_apache_fix) ? 
+                need_min_apache_fix("2.2.33", "2.4.26", "2.5.0") : 
+                need_min_apache_version('2.4.26');
 
 plan tests => scalar(@test_cases) * 2 + $test_fold * 2,
      need_min_apache_version('2.2.32');



Mime
View raw message