httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From build...@apache.org
Subject svn commit: r1015401 - in /websites/staging/httpd/trunk/content: ./ security/vulnerabilities-httpd.xml security/vulnerabilities_22.html security/vulnerabilities_24.html
Date Thu, 13 Jul 2017 13:01:50 GMT
Author: buildbot
Date: Thu Jul 13 13:01:50 2017
New Revision: 1015401

Log:
Staging update by buildbot for httpd

Modified:
    websites/staging/httpd/trunk/content/   (props changed)
    websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml
    websites/staging/httpd/trunk/content/security/vulnerabilities_22.html
    websites/staging/httpd/trunk/content/security/vulnerabilities_24.html

Propchange: websites/staging/httpd/trunk/content/
------------------------------------------------------------------------------
--- cms:source-revision (original)
+++ cms:source-revision Thu Jul 13 13:01:50 2017
@@ -1 +1 @@
-1801734
+1801835

Modified: websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml
==============================================================================
--- websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml (original)
+++ websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml Thu Jul 13 13:01:50
2017
@@ -1,5 +1,105 @@
 <security updated="20170619">
 
+<issue fixed="2.4.27" reported="20170630" public="20170711" released="20170711">
+<cve name="CVE-2017-9789"/>
+<severity level="2">important</severity>
+<title>Read after free in mod_http2</title>
+<description><p>
+When under stress, closing many connections, the HTTP/2
+handling code would sometimes access memory after it has
+been freed, resulting in potentially erratic behaviour.
+</p></description>
+<acknowledgements>
+We would like to thank Robert Święcki for reporting this issue.
+</acknowledgements>
+<affects prod="httpd" version="2.4.26"/>
+</issue>
+
+<issue fixed="2.4.27" reported="20170628" public="20170711" released="20170711">
+<cve name="CVE-2017-9788"/>
+<severity level="2">important</severity>
+<title>Uninitialized memory reflection in mod_auth_digest</title>
+<description><p>
+The value placeholder in [Proxy-]Authorization headers
+of type 'Digest' was not initialized or reset
+before or between successive key=value assignments.
+by mod_auth_digest.
+</p><p>
+Providing an initial key with no '=' assignment
+could reflect the stale value of uninitialized pool
+memory used by the prior request, leading to leakage
+of potentially confidential information, and a segfault.
+</p></description>
+<acknowledgements>
+We would like to thank Robert Święcki for reporting this issue.
+</acknowledgements>
+<affects prod="httpd" version="2.4.26"/>
+<affects prod="httpd" version="2.4.25"/>
+<affects prod="httpd" version="2.4.23"/>
+<affects prod="httpd" version="2.4.20"/>
+<affects prod="httpd" version="2.4.18"/>
+<affects prod="httpd" version="2.4.17"/>
+<affects prod="httpd" version="2.4.16"/>
+<affects prod="httpd" version="2.4.12"/>
+<affects prod="httpd" version="2.4.10"/>
+<affects prod="httpd" version="2.4.9"/>
+<affects prod="httpd" version="2.4.7"/>
+<affects prod="httpd" version="2.4.6"/>
+<affects prod="httpd" version="2.4.4"/>
+<affects prod="httpd" version="2.4.3"/>
+<affects prod="httpd" version="2.4.2"/>
+<affects prod="httpd" version="2.4.1"/>
+</issue>
+
+<issue fixed="2.2.34" reported="20170628" public="20170711" released="20170711">
+<cve name="CVE-2017-9788"/>
+<severity level="2">important</severity>
+<title>Uninitialized memory reflection in mod_auth_digest</title>
+<description><p>
+The value placeholder in [Proxy-]Authorization headers
+of type 'Digest' was not initialized or reset
+before or between successive key=value assignments.
+by mod_auth_digest.
+</p><p>
+Providing an initial key with no '=' assignment
+could reflect the stale value of uninitialized pool
+memory used by the prior request, leading to leakage
+of potentially confidential information, and a segfault.
+</p></description>
+<acknowledgements>
+We would like to thank Robert Święcki for reporting this issue.
+</acknowledgements>
+<affects prod="httpd" version="2.2.32"/>
+<affects prod="httpd" version="2.2.31"/>
+<affects prod="httpd" version="2.2.29"/>
+<affects prod="httpd" version="2.2.27"/>
+<affects prod="httpd" version="2.2.26"/>
+<affects prod="httpd" version="2.2.25"/>
+<affects prod="httpd" version="2.2.24"/>
+<affects prod="httpd" version="2.2.23"/>
+<affects prod="httpd" version="2.2.22"/>
+<affects prod="httpd" version="2.2.21"/>
+<affects prod="httpd" version="2.2.20"/>
+<affects prod="httpd" version="2.2.19"/>
+<affects prod="httpd" version="2.2.18"/>
+<affects prod="httpd" version="2.2.17"/>
+<affects prod="httpd" version="2.2.16"/>
+<affects prod="httpd" version="2.2.15"/>
+<affects prod="httpd" version="2.2.14"/>
+<affects prod="httpd" version="2.2.13"/>
+<affects prod="httpd" version="2.2.12"/>
+<affects prod="httpd" version="2.2.11"/>
+<affects prod="httpd" version="2.2.10"/>
+<affects prod="httpd" version="2.2.9"/>
+<affects prod="httpd" version="2.2.8"/>
+<affects prod="httpd" version="2.2.6"/>
+<affects prod="httpd" version="2.2.5"/>
+<affects prod="httpd" version="2.2.4"/>
+<affects prod="httpd" version="2.2.3"/>
+<affects prod="httpd" version="2.2.2"/>
+<affects prod="httpd" version="2.2.0"/>
+</issue>
+
 <issue fixed="2.4.26" reported="20170206" public="20170619" released="20170619">
 <cve name="CVE-2017-3167"/>
 <severity level="2">important</severity>

Modified: websites/staging/httpd/trunk/content/security/vulnerabilities_22.html
==============================================================================
--- websites/staging/httpd/trunk/content/security/vulnerabilities_22.html (original)
+++ websites/staging/httpd/trunk/content/security/vulnerabilities_22.html Thu Jul 13 13:01:50
2017
@@ -111,6 +111,38 @@ Fixed in Apache httpd 2.2.34</h1><dl>
   <dd>
     <b>important: </b>
     <b>
+      <name name="CVE-2017-9788">Uninitialized memory reflection in mod_auth_digest</name>
+    </b>
+    <a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9788">CVE-2017-9788</a>
+    <p>
+The value placeholder in [Proxy-]Authorization headers
+of type 'Digest' was not initialized or reset
+before or between successive key=value assignments.
+by mod_auth_digest.
+</p>
+    <p>
+Providing an initial key with no '=' assignment
+could reflect the stale value of uninitialized pool
+memory used by the prior request, leading to leakage
+of potentially confidential information, and a segfault.
+</p>
+  </dd>
+  <dd>
+    <p>Acknowledgements: 
+We would like to thank Robert Święcki for reporting this issue.
+</p>
+  </dd>
+  <dd>
+  Reported to security team: 28th June 2017<br/>
+  Issue public: 11th July 2017<br/></dd>
+  <dd>
+  Update Released: 11th July 2017<br/></dd>
+  <dd>
+      Affects: 
+    2.2.32, 2.2.31, 2.2.29, 2.2.27, 2.2.26, 2.2.25, 2.2.24, 2.2.23, 2.2.22, 2.2.21, 2.2.20,
2.2.19, 2.2.18, 2.2.17, 2.2.16, 2.2.15, 2.2.14, 2.2.13, 2.2.12, 2.2.11, 2.2.10, 2.2.9, 2.2.8,
2.2.6, 2.2.5, 2.2.4, 2.2.3, 2.2.2, 2.2.0<p/></dd>
+  <dd>
+    <b>important: </b>
+    <b>
       <name name="CVE-2017-3167">ap_get_basic_auth_pw() Authentication Bypass</name>
     </b>
     <a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-3167">CVE-2017-3167</a>

Modified: websites/staging/httpd/trunk/content/security/vulnerabilities_24.html
==============================================================================
--- websites/staging/httpd/trunk/content/security/vulnerabilities_24.html (original)
+++ websites/staging/httpd/trunk/content/security/vulnerabilities_24.html Thu Jul 13 13:01:50
2017
@@ -106,7 +106,66 @@ in a "-dev" release then this means that
 the development source tree and will be part of an upcoming full release.</p><p>
This page is created from a database of vulnerabilities originally
 populated by Apache Week.  Please send comments or corrections for
 these vulnerabilities to the <a href="/security_report.html">Security
-Team</a>.  </p><p><em>The initial GA release, Apache httpd 2.4.1,
includes fixes for all vulnerabilities which have been resolved in Apache httpd 2.2.22 and
all older releases.  Consult the <a href="vulnerabilities_22.html">Apache httpd 2.2
vulnerabilities list</a> for more information.</em></p><h1 id="2.4.26">
+Team</a>.  </p><p><em>The initial GA release, Apache httpd 2.4.1,
includes fixes for all vulnerabilities which have been resolved in Apache httpd 2.2.22 and
all older releases.  Consult the <a href="vulnerabilities_22.html">Apache httpd 2.2
vulnerabilities list</a> for more information.</em></p><h1 id="2.4.27">
+Fixed in Apache httpd 2.4.27</h1><dl>
+  <dd>
+    <b>important: </b>
+    <b>
+      <name name="CVE-2017-9789">Read after free in mod_http2</name>
+    </b>
+    <a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9789">CVE-2017-9789</a>
+    <p>
+When under stress, closing many connections, the HTTP/2
+handling code would sometimes access memory after it has
+been freed, resulting in potentially erratic behaviour.
+</p>
+  </dd>
+  <dd>
+    <p>Acknowledgements: 
+We would like to thank Robert Święcki for reporting this issue.
+</p>
+  </dd>
+  <dd>
+  Reported to security team: 30th June 2017<br/>
+  Issue public: 11th July 2017<br/></dd>
+  <dd>
+  Update Released: 11th July 2017<br/></dd>
+  <dd>
+      Affects: 
+    2.4.26<p/></dd>
+  <dd>
+    <b>important: </b>
+    <b>
+      <name name="CVE-2017-9788">Uninitialized memory reflection in mod_auth_digest</name>
+    </b>
+    <a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9788">CVE-2017-9788</a>
+    <p>
+The value placeholder in [Proxy-]Authorization headers
+of type 'Digest' was not initialized or reset
+before or between successive key=value assignments.
+by mod_auth_digest.
+</p>
+    <p>
+Providing an initial key with no '=' assignment
+could reflect the stale value of uninitialized pool
+memory used by the prior request, leading to leakage
+of potentially confidential information, and a segfault.
+</p>
+  </dd>
+  <dd>
+    <p>Acknowledgements: 
+We would like to thank Robert Święcki for reporting this issue.
+</p>
+  </dd>
+  <dd>
+  Reported to security team: 28th June 2017<br/>
+  Issue public: 11th July 2017<br/></dd>
+  <dd>
+  Update Released: 11th July 2017<br/></dd>
+  <dd>
+      Affects: 
+    2.4.26, 2.4.25, 2.4.23, 2.4.20, 2.4.18, 2.4.17, 2.4.16, 2.4.12, 2.4.10, 2.4.9, 2.4.7,
2.4.6, 2.4.4, 2.4.3, 2.4.2, 2.4.1<p/></dd>
+</dl><h1 id="2.4.26">
 Fixed in Apache httpd 2.4.26</h1><dl>
   <dd>
     <b>important: </b>



Mime
View raw message