httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From build...@apache.org
Subject svn commit: r958690 - in /websites/staging/httpd/trunk/content: ./ security/vulnerabilities-httpd.xml security/vulnerabilities_24.html
Date Fri, 17 Jul 2015 14:31:58 GMT
Author: buildbot
Date: Fri Jul 17 14:31:58 2015
New Revision: 958690

Log:
Staging update by buildbot for httpd

Modified:
    websites/staging/httpd/trunk/content/   (props changed)
    websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml
    websites/staging/httpd/trunk/content/security/vulnerabilities_24.html

Propchange: websites/staging/httpd/trunk/content/
------------------------------------------------------------------------------
--- cms:source-revision (original)
+++ cms:source-revision Fri Jul 17 14:31:58 2015
@@ -1 +1 @@
-1691570
+1691571

Modified: websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml
==============================================================================
--- websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml (original)
+++ websites/staging/httpd/trunk/content/security/vulnerabilities-httpd.xml Fri Jul 17 14:31:58
2015
@@ -1,5 +1,28 @@
 <security updated="20150717">
 
+<issue fixed="2.4.16" reported="20150128" public="20150204" released="20150715">
+<cve name="CVE-2015-0228"/>
+<severity level="4">low</severity>
+<title>mod_lua: Crash in websockets PING handling</title>
+<description><p>
+
+  A stack recursion crash in the mod_lua module was found.  A Lua
+  script executing the r:wsupgrade() function could crash the process
+  if a malicious client sent a carefully crafted PING request.  This
+  issue affected releases 2.4.7 through 2.4.12 inclusive.
+  
+</p></description>
+<affects prod="httpd" version="2.4.12"/>
+<affects prod="httpd" version="2.4.10"/>
+<affects prod="httpd" version="2.4.9"/>
+<affects prod="httpd" version="2.4.8"/>
+<affects prod="httpd" version="2.4.7"/>
+<acknowledgements>
+This issue was reported by Guido Vranken.
+</acknowledgements>
+</issue>
+
+  
 <issue fixed="2.4.16" reported="20150203" public="20150305" released="20150715">
 <cve name="CVE-2015-0253"/>
 <severity level="4">low</severity>

Modified: websites/staging/httpd/trunk/content/security/vulnerabilities_24.html
==============================================================================
--- websites/staging/httpd/trunk/content/security/vulnerabilities_24.html (original)
+++ websites/staging/httpd/trunk/content/security/vulnerabilities_24.html Fri Jul 17 14:31:58
2015
@@ -99,6 +99,34 @@ Fixed in Apache httpd 2.4.16</h1><dl>
   <dd>
     <b>low: </b>
     <b>
+      <name name="CVE-2015-0228">mod_lua: Crash in websockets PING handling</name>
+    </b>
+    <a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0228">CVE-2015-0228</a>
+    <p>
+
+  A stack recursion crash in the mod_lua module was found.  A Lua
+  script executing the r:wsupgrade() function could crash the process
+  if a malicious client sent a carefully crafted PING request.  This
+  issue affected releases 2.4.7 through 2.4.12 inclusive.
+  
+</p>
+  </dd>
+  <dd>
+    <p>Acknowledgements: 
+This issue was reported by Guido Vranken.
+</p>
+  </dd>
+  <dd>
+  Reported to security team: 28th January 2015<br/>
+  Issue public: 4th February 2015<br/></dd>
+  <dd>
+  Update Released: 15th July 2015<br/></dd>
+  <dd>
+      Affects: 
+    2.4.12, 2.4.10, 2.4.9, 2.4.8, 2.4.7<p/></dd>
+  <dd>
+    <b>low: </b>
+    <b>
       <name name="CVE-2015-0253">Crash in ErrorDocument 400 handling</name>
     </b>
     <a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0253">CVE-2015-0253</a>



Mime
View raw message