httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From traw...@apache.org
Subject svn commit: r918562 - /httpd/httpd/trunk/modules/session/mod_session_crypto.c
Date Wed, 03 Mar 2010 16:44:57 GMT
Author: trawick
Date: Wed Mar  3 16:44:57 2010
New Revision: 918562

URL: http://svn.apache.org/viewvc?rev=918562&view=rev
Log:
use separate #error message when APR[-Util] is of a valid
version but wasn't built with crypto support

Modified:
    httpd/httpd/trunk/modules/session/mod_session_crypto.c

Modified: httpd/httpd/trunk/modules/session/mod_session_crypto.c
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/session/mod_session_crypto.c?rev=918562&r1=918561&r2=918562&view=diff
==============================================================================
--- httpd/httpd/trunk/modules/session/mod_session_crypto.c (original)
+++ httpd/httpd/trunk/modules/session/mod_session_crypto.c Wed Mar  3 16:44:57 2010
@@ -21,7 +21,15 @@
 #include "apr_strings.h"
 #include "http_log.h"
 
-#if (APU_MAJOR_VERSION > 1 || (APU_MAJOR_VERSION == 1 && APU_MINOR_VERSION >=
4)) && APU_HAVE_CRYPTO > 0
+#if APU_MAJOR_VERSION == 1 && APU_MINOR_VERSION < 4
+
+#error session_crypto_module requires APR v1.4.0 or later
+
+#elif APU_HAVE_CRYPTO == 0
+
+#error Crypto support must be enabled in APR
+
+#else
 
 #include "apr_crypto.h"                /* for apr_*_crypt et al */
 
@@ -598,6 +606,4 @@
     register_hooks                    /* register hooks */
 };
 
-#else
-#error session_crypto_module requires APR v1.4.0 or later
 #endif



Mime
View raw message