httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From m..@apache.org
Subject svn commit: r918090 - in /httpd/site/trunk: docs/security/vulnerabilities-oval.xml docs/security/vulnerabilities_22.html xdocs/security/vulnerabilities-httpd.xml
Date Tue, 02 Mar 2010 16:01:26 GMT
Author: mjc
Date: Tue Mar  2 16:01:25 2010
New Revision: 918090

URL: http://svn.apache.org/viewvc?rev=918090&view=rev
Log:
Add CVE-2010-0408 public via http://svn.apache.org/viewvc?view=revision&revision=917876

Modified:
    httpd/site/trunk/docs/security/vulnerabilities-oval.xml
    httpd/site/trunk/docs/security/vulnerabilities_22.html
    httpd/site/trunk/xdocs/security/vulnerabilities-httpd.xml

Modified: httpd/site/trunk/docs/security/vulnerabilities-oval.xml
URL: http://svn.apache.org/viewvc/httpd/site/trunk/docs/security/vulnerabilities-oval.xml?rev=918090&r1=918089&r2=918090&view=diff
==============================================================================
--- httpd/site/trunk/docs/security/vulnerabilities-oval.xml (original)
+++ httpd/site/trunk/docs/security/vulnerabilities-oval.xml Tue Mar  2 16:01:25 2010
@@ -5,6 +5,41 @@
 <oval:timestamp>2005-10-12T18:13:45</oval:timestamp>
 </generator>
 <definitions>
+<definition id="oval:org.apache.httpd:def:20100408" version="1" class="vulnerability">
+<metadata>
+<title>mod_proxy_ajp DoS</title>
+<reference source="CVE" ref_id="CVE-2010-0408" ref_url="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0408"/>
+<description>
+mod_proxy_ajp would return the wrong status code if it encountered
+an error causing a backend server to be put into an error state
+until the retry timeout expired.  A remote attacker could send 
+malicious requests to trigger this issue, resulting in a
+denial of service.
+</description>
+<apache_httpd_repository>
+<public>20100302</public>
+<reported>20100202</reported>
+<released/>
+<severity level="3">moderate</severity>
+</apache_httpd_repository>
+</metadata>
+<criteria operator="OR">
+<criteria operator="OR">
+<criterion test_ref="oval:org.apache.httpd:tst:2214" comment="the version of httpd is
2.2.14"/>
+<criterion test_ref="oval:org.apache.httpd:tst:2213" comment="the version of httpd is
2.2.13"/>
+<criterion test_ref="oval:org.apache.httpd:tst:2212" comment="the version of httpd is
2.2.12"/>
+<criterion test_ref="oval:org.apache.httpd:tst:2211" comment="the version of httpd is
2.2.11"/>
+<criterion test_ref="oval:org.apache.httpd:tst:229" comment="the version of httpd is 2.2.9"/>
+<criterion test_ref="oval:org.apache.httpd:tst:228" comment="the version of httpd is 2.2.8"/>
+<criterion test_ref="oval:org.apache.httpd:tst:226" comment="the version of httpd is 2.2.6"/>
+<criterion test_ref="oval:org.apache.httpd:tst:225" comment="the version of httpd is 2.2.5"/>
+<criterion test_ref="oval:org.apache.httpd:tst:224" comment="the version of httpd is 2.2.4"/>
+<criterion test_ref="oval:org.apache.httpd:tst:223" comment="the version of httpd is 2.2.3"/>
+<criterion test_ref="oval:org.apache.httpd:tst:222" comment="the version of httpd is 2.2.2"/>
+<criterion test_ref="oval:org.apache.httpd:tst:220" comment="the version of httpd is 2.2.0"/>
+</criteria>
+</criteria>
+</definition>
 <definition id="oval:org.apache.httpd:def:20092699" version="1" class="vulnerability">
 <metadata>
 <title>Solaris pollset DoS</title>
@@ -3280,6 +3315,10 @@
 </definition>
 </definitions>
 <tests>
+<httpd_test xmlns="http://oval.mitre.org/XMLSchema/oval-definitions-5#apache" id="oval:org.apache.httpd:tst:2214"
version="1" comment="the version of httpd is 2.2.14" check="at least one">
+<object object_ref="oval:org.apache.httpd:obj:1"/>
+<state state_ref="oval:org.apache.httpd:ste:2214"/>
+</httpd_test>
 <httpd_test xmlns="http://oval.mitre.org/XMLSchema/oval-definitions-5#apache" id="oval:org.apache.httpd:tst:2213"
version="1" comment="the version of httpd is 2.2.13" check="at least one">
 <object object_ref="oval:org.apache.httpd:obj:1"/>
 <state state_ref="oval:org.apache.httpd:ste:2213"/>
@@ -3537,6 +3576,9 @@
 </httpd_object>
 </objects>
 <states>
+<httpd_state xmlns="http://oval.mitre.org/XMLSchema/oval-definitions-5#apache" id="oval:org.apache.httpd:ste:2214"
version="1" comment="the version of httpd is 2.2.14">
+<version operation="equals" datatype="version">2.2.14</version>
+</httpd_state>
 <httpd_state xmlns="http://oval.mitre.org/XMLSchema/oval-definitions-5#apache" id="oval:org.apache.httpd:ste:2213"
version="1" comment="the version of httpd is 2.2.13">
 <version operation="equals" datatype="version">2.2.13</version>
 </httpd_state>

Modified: httpd/site/trunk/docs/security/vulnerabilities_22.html
URL: http://svn.apache.org/viewvc/httpd/site/trunk/docs/security/vulnerabilities_22.html?rev=918090&r1=918089&r2=918090&view=diff
==============================================================================
--- httpd/site/trunk/docs/security/vulnerabilities_22.html [utf-8] (original)
+++ httpd/site/trunk/docs/security/vulnerabilities_22.html [utf-8] Tue Mar  2 16:01:25 2010
@@ -91,6 +91,40 @@
  <tr>
  <td bgcolor="#525D76">
   <font color="#ffffff" face="arial,helvetica,sanserif">
+   <a name="2.2.15-cvs"><strong>Fixed in Apache httpd 2.2.15-cvs</strong></a>
+  </font>
+ </td>
+ </tr>
+ <tr><td>
+  <blockquote>
+<dl>
+<dd>
+<b>moderate: </b>
+<b>
+<name name="CVE-2010-0408">mod_proxy_ajp DoS</name>
+</b>
+<a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0408">CVE-2010-0408</a>
+<p>
+mod_proxy_ajp would return the wrong status code if it encountered
+an error causing a backend server to be put into an error state
+until the retry timeout expired.  A remote attacker could send 
+malicious requests to trigger this issue, resulting in a
+denial of service.
+</p>
+</dd>
+<dd />
+<dd>
+      Affects: 
+    2.2.14, 2.2.13, 2.2.12, 2.2.11, 2.2.9, 2.2.8, 2.2.6, 2.2.5, 2.2.4, 2.2.3, 2.2.2, 2.2.0<p
/>
+</dd>
+</dl>
+  </blockquote>
+ </td></tr>
+</table>
+           <table border="0" cellspacing="0" cellpadding="2" width="100%">
+ <tr>
+ <td bgcolor="#525D76">
+  <font color="#ffffff" face="arial,helvetica,sanserif">
    <a name="2.2.14"><strong>Fixed in Apache httpd 2.2.14</strong></a>
   </font>
  </td>

Modified: httpd/site/trunk/xdocs/security/vulnerabilities-httpd.xml
URL: http://svn.apache.org/viewvc/httpd/site/trunk/xdocs/security/vulnerabilities-httpd.xml?rev=918090&r1=918089&r2=918090&view=diff
==============================================================================
--- httpd/site/trunk/xdocs/security/vulnerabilities-httpd.xml [utf-8] (original)
+++ httpd/site/trunk/xdocs/security/vulnerabilities-httpd.xml [utf-8] Tue Mar  2 16:01:25
2010
@@ -1,4 +1,29 @@
-<security updated="20091006">
+<security updated="20100302">
+
+<issue fixed="2.2.15-cvs" reported="20100202" public="20100302" released="">
+<cve name="CVE-2010-0408"/>
+<severity level="3">moderate</severity>
+<title>mod_proxy_ajp DoS</title>
+<description><p>
+mod_proxy_ajp would return the wrong status code if it encountered
+an error causing a backend server to be put into an error state
+until the retry timeout expired.  A remote attacker could send 
+malicious requests to trigger this issue, resulting in a
+denial of service.
+</p></description>
+<affects prod="httpd" version="2.2.14"/>
+<affects prod="httpd" version="2.2.13"/>
+<affects prod="httpd" version="2.2.12"/>
+<affects prod="httpd" version="2.2.11"/>
+<affects prod="httpd" version="2.2.9"/>
+<affects prod="httpd" version="2.2.8"/>
+<affects prod="httpd" version="2.2.6"/>
+<affects prod="httpd" version="2.2.5"/>
+<affects prod="httpd" version="2.2.4"/>
+<affects prod="httpd" version="2.2.3"/>
+<affects prod="httpd" version="2.2.2"/>
+<affects prod="httpd" version="2.2.0"/>
+</issue>
 
 <issue fixed="2.2.14" reported="20090805" public="20090923" released="20091005">
 <cve name="CVE-2009-2699"/>



Mime
View raw message