httpd-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject svn commit: r782399 - /httpd/httpd/branches/2.2.x/README-win32.txt
Date Sun, 07 Jun 2009 15:29:23 GMT
Author: wrowe
Date: Sun Jun  7 15:29:21 2009
New Revision: 782399

Add windows build notes before any 2.2.X release, which should help
users with the integration notes for obtaining 3rd party db drivers.

This file was shipped in the tarball as a dist artifact, but it
better belongs in the httpd tree to warn users about the first pipe
handling issue if they are rolling their own.


Added: httpd/httpd/branches/2.2.x/README-win32.txt
--- httpd/httpd/branches/2.2.x/README-win32.txt (added)
+++ httpd/httpd/branches/2.2.x/README-win32.txt Sun Jun  7 15:29:21 2009
@@ -0,0 +1,57 @@
+New version of APR
+Note that the included APR is now version 1.3, which adds several
+subtle changes in the behavior of file handling, pipes and process
+creation.  Most importantly, there is finer control over the handles
+inherited by processes, so the mod_fastcgi or mod_fcgid modules must 
+be updated for httpd-2.2.9 to run correctly on Windows.
+Most other third party modules are unaffected by this change.
+Source corrections applied
+The package includes corrections to the
+build file so that .mak based builds work.  The package also corrects
+the default to disable IPV6 support.  These patches are summarized in
+the httpd-2.2.9-win32-src.applied.patch file.
+Connecting to databases
+With APR-util 1.3.0, the MySQL and FreeTDS drivers do not compile
+on Windows.  There is no Microsoft SQL Server client or ODBC client
+at the present time.
+Three driver connectors are provided in the binary distribution, for
+SQLite3, PostgreSQL and Oracle.  They require you to install the actual 
+corresponding client drivers.
+The binary file can be obtained from;
+note that this binary was built with version 3.5.9 (earlier and
+later version 3.5 driver .dll's may work.)
+The Oracle Instant Client - Basic driver can be obtained from
+and note that this binary was built against version,
+other version 11.1 drivers may work.
+The PostgreSQL binaries may be obtained from
+and note that this binary was built against version 8.3.1-1, and
+again it may work with other 8.1 version .dll's.
+For whichever database backend you configure, the corresponding driver
+.dll's must be in your PATH (and in the systemwide path if used for 
+a service such as Apache httpd).

View raw message